Styles line weight

I’m setting up view ports in layout and trying to get the line weight to reduce to increase resolution. In the ‘SketchUp Model’ palette in ‘Styles’ there is a button called ‘line weight’ (bottom right of the palette above render options). This is set to 0.5, I know it can be set to 0.1 but don’t seem to be able to alter the field. I know it can be reset - does anyone know how? Is it a Layout issue of a variable in the SketchUp model?

02

You need to select one or more viewports before you can change the Lineweight multiplier.

Thanks Dave, I’ve been making sure I’ve done this but when I try to type in a new value for the resolution nothing happens, the box highlights as though it can be edited but it doest register any change. If I press delete to enter a new value, then the entire view port disappears and it wont let me input another value.

That’s odd. What happens if you type a larger value? Say 2 or 3? You won’t see the lines get much thinner if at all when typing lower values unless you zoom in very tight on the model.

You are making sure to prevent the scenes from showing as modified, right?

Just given that a try and its not worked - still won’t let me edit. I’m a fairly new to Layout so forgive me, I’m not sure what your last sentence means about preventing scenes from showing as modified.

In terms of relative image quality, please see image attached. The one on the left is the problem view port, the lines are to weighty for my taste, the image to the right is one previously prepared. The only difference I can see is that pesky line weight number. The left hand image is set to 0.5 the right hand image is set at 0.1.

05

I have a hunch it may be to do with Styles in the SketcUp model, but there’s nothing obvious to suggest altering line weights, only ‘profiles’ in the style settings.

Could you share the LayOut file?

Just given that a try, but the file is too big to up load to the forum.

Drop box and share the link.

I’d be happy to do that, but I’ve just had a cup of tea and figured out a work around that has, well, worked. I’ve taken the layout file with the desired settings and turned it into a template, then sent the new model to that template and its looking good. I don’t like mysteries though, so if you are willing to have a look, let me know your e-mail address and I will set up an ‘can edit’ drop box link to the file for you. I’ll fully understand if you have better things to do!

I’m happy enough with this now, but curious about how to solve the issue rather than work around it.

04

I’m willing to have a look. Just leaving now to attend the visitation after the passing of my mother-in-law. It’ll be later tonight before I can get a look. If you don’t want to make your file public, feel free to send the link to me via private message. click on my name or avatar and the the Message button.

Thanks Dave, and I’m very sorry for your loss. My mother in law passed away 4 years ago, its a tough time for the family.

I’m not on Dropbox Plus so I can’t enable permissions through a shared link, I can only do this via an e-mail link. if you are still up for the challenge, then pm me an e-mail address and I will share the file link, obviously not a problem if you’d rather not do this - its going the extra mile, then adding another for fun!

I’m UK based so just winding down for the evening, so I may not get around to posting a link for another 12 hours or so. In the mean time, huge thanks for taking the time and being willing to help out.

Thank you, sir.

I’ve looked at the file you sent. Here are a couple of things.


Notice in the SketchUp Model window, the scene is shown as modified. This means that any scene-specific changes you make in the SketchUp file won’t get displayed in the viewport. The viewport is essentially disconnected from the scene. There are various things that result in the scene becoming modified. Double clicking in a viewport to move the camera (Zoom, Orbit, Pan), Setting a standard view in the SketchUp Model window or clicking on Ortho, Shadows, or Fog do it. Also choosing a different style in the Styles tab in LO will do it.

Having those settings in LO is handy if you want to make a down and dirty quick document to send off to someone but for larger or more involved projects, it’s best to keep your mitts off those things. Instead, make any settings in the SketchUp file. Doing it in advance is best but can require planning ahead. Planning ahead prevents flying into a box canyon anyway. :wink:

If you need to make changes later, go back to the SketchUp file and make them. Update the scenes as needed and save the file. Then you can update the reference in LO and see those changes reflected in the associated viewports.

So in your case, you edited the style in SU but the changes weren’t showing up in the viewport because it is no longer showing the scene.

I selected the Front Elevation scene from the list to get back to the scene. Notice the change in the appearance of the model.
Screenshot - 9_22_2017 , 6_15_54 AM

As for the lineweight setting, the change doesn’t show that much on screen when you’re working in LO. Especially when you are setting the lineweight multiplier low. If it did, some lines would disappear because they’d be narrower than the screen pixels. Generally you want to keep Display Resolution set to Medium to help improve performance and keep you working quickly. You can change that in File>Document Setup>Paper but it’s probably not worth going to High in most cases. You can also set the Output resolution to High if you find Medium doesn’t cut it in your PDF exports.

In the attached PDF, the lineweight multiplier for the top viewport is set to 0.20 and the bottom one to 0.50. If you zoom in to say 200 percent, you can easily see the difference. If you print it out, I think the difference will be more noticeable on paper.
G 25 02 (21.09.17) forum.pdf (328.9 KB)

We need to talk about your workflow in SketchUp but that’ll be for a different conversation.

1 Like

Nice Elev Jon !

Wow, thanks Dave - your comments are accurate - I’m making it up as I go along! My main tool is Autocad, I’ve picked up Sketchup along the way and not spent a whole lot of time on formal learning - so yes, I’m sure my work flow is VERY in-efficient.

Cheers for now

Jon

Thanks gsharp.

The Render setting in Sketchup Model can change the appearance…try changing from Hybrid to Raster

Yes. They can. That wasn’t the issue in this instance, though.

I always keep my Display resolution Low and Output resolution High. In real world terms low means 72 dpi and high 300.
The line weight setting in the SketcUp model tray shows the weight that will be applied to edges that use the 1 pixel weight in the model, and the thicker profiles and section cut edges will use multiples of that base weight.

Thanks Randini 5. I use rasta mode for setting up the drawings and view ports and hybrid for the final render. Raster uses less memory so faster when manipulating view ports, I like the hybrid final output - it’s all personal choice in the end.