Line weight in SketchUp

Hello all,
This is my first time participating in the community chat. I’m a structural mason and Sketchup has really revolutionized my design process over the last decade or so. I’m coming off of an older version of SU where I enjoyed the ability to edit the line weight of a model to 1. I still have the same ability with the current SU version, but even when reduced to 1, the line weight is quite heavier than it use to be in the same setting, which leaves this bolder lined cartoon effect imo. Is there a work around to get the line crisper?
Any help would be greatly appreciated.

hello commonbond and welcome,

Two things you can do :

  • verify if profiles are on ( view > edge style) and uncheck if they are.

  • go to window > preferences > openGL, and increase multisample Anti-aliasing. If it is set to 0x, no wonder you feel like lines are thick

it could also be the whole style you’d have changed, but let’s start with this

What was the older version you are comparing to?

Since there’s really no line weight setting in SketchUp I gather you are referring to the weight of Profile edges. Is that correct?

Have a look at the settings in Preferences>OpenGL. You may be able to make some adjustment there.

I increased the anti-aliasing from 4x to 8x and have seen no change. The older version I’ve been using (15.3.329) is quite crisp when I set the profile at 1. Setting the current version profile to 1 is substantially heavier. What she be my next move?

Yes, I am referring to the profile.
I changed anti-aliasing from 4x to 8x. She I have gone in the other direction to 0x?

can you tell me what’s in graphics card details in the very same window ?
can you share your file ? since you’re new, you won’t be able to upload it here yet. but you can upload it on and paste the link here

You can try going to 0x.

The graphics pipeline has changed quite a lot from SU2015. Did you have Hardware Acceleration turned off in 2015? If so, that could also have an impact. Turning off Hardware Acceleration dumped rendering duties to the CPU. That option was removed a few years ago which means the graphics card has to do the heavy lifting.

Maybe Tom @TDahl knows, there might be a setting that can be set in the terminal.

I am not aware of “hidden” configurable settings that affect how lines (edges or profiles) are drawn by SketchUp.

For what it’s worth, SketchUp made a change in graphic rendering starting in ~2017 or so concerning how high-resolution displays are handled. Previously, for edges or profiles set to width 1 in the GUI, SketchUp drew lines that were 1 display-hardware pixel wide. On a 4K or 5K display, such lines were super fine and beautiful! I had gotten used to that behavior on a 5K iMac with SketchUp Pro 2016, and loved the detailed appearance of models with complex geometry. (This also affected how lines were rendered in 2D JPEG exports - nice and thin.)

I now use SketchUp Pro 2018, which was “enhanced” with more explicit support for high-resolution displays. Although 2018 has some nice improvements compared to 2016, one regression (in my mind) is that lines are now drawn much thicker as compared to 2016. As far as I know, it is no longer possible to convince SketchUp to render edges as 1-pixel wide lines on high-resolution displays. (Exported 2D JPEGs now have thicker lines as well. I seem to recall that a newer version of SketchUp may provide direct user control over JPEG line thickness? When I want thin JPEG lines from 2018, I export a bigger image and then scale the image down in an image editor.)

This is so helpful! Prevents the ongoing proverbial goose chase. Are there any hunches as to why the single pixel width profile, with all it’s cleanness and precision is no longer on offer? Feels like a fairly profound misstep imo. I don’t know why its not a default setting actually. The aesthetic seems so obvious. Thoughts?

I cannot speak to the motivations of the SketchUp developers. My guess is that the goal was to ensure that lines rendered in the viewport would appear similar on all displays, regardless of display resolution. The thickness unit in the Styles window fields (for profiles, edges, etc.) was probably redefined to be a virtual pixel value, normalized based on an HD-class display of some typical physical size.

Regardless, I wish it were still possible for SketchUp to render edges in a viewport as approximately 1-pixel wide on 4K and 5K displays.