Styles and curves


#1

Hi is it possible to get the sketchy styles to display curved/complex objects well, whenever i use an interesting style to help sell the drawing it misses a lot of the detail does anyone have any advice for this? I dont particlary want to do realistic renders just tradtional line drawings and a good perspective view that doesn’t look carton like, i link to my example…

thanks
link to example


#2

• Zoom in as close as you can.
Sketchy Edge styles automatically render less and less detail as camera distance increases.

• Adjust the Level of Detail slider in the Styles browser.



#3

ok thanks so it can’t really do it and the views i would like it to be able to. I might keep searching for other styles i could use. my other issue is can I adjust the face shading on the default style for example (the woodwork style) I would like it to look less heavy the only adjustments i can find are for shadow which is different as I understand. or Am I going about this the wrong way?
Thanks
ferg


#4

Since you’re posting in the SU Pro category, I presume you have SU Pro, which includes Style Builder.
You might try creating your own sketchy style; one which includes a number of very short strokes.
The shorter length strokes may help render the tiny details you’re after.

Try enabling Use Sun for Shading and then adjusting the Time; Date; Light and Dark sliders.



#5

i’m not sure if this applies to your model but…

using unwelded curves vs welded curves can cause certain styles to display incorrectly… loss of detail, missing elements, etc.


[EDIT]

here’s an example of what i mean:

here’s the .skp to play with… switch through various styles with this model and you’ll see the difference between welded edges and non-welded

weldedgesstyles.skp (2.5 MB)


#6

thanks this could be my main issue is there a simple way to make sure they are all connected joined?
or do you have to weld individually?

I am also still struggling with shading shadow thing. What I want to be able to do is set my scene up and use the face shading that is in the default styles except turn it down a bit so its not so heavy, whenever i use the shadow option it shades from one angle only, i might just be barking up the wrong tree with what i want to achive!
I appreciate all your help with this as displaying the model well is a big factor in us winning the jobs


#7

[quote=“ferg, post:6, topic:9060, full:true”]
thanks this could be my main issue is there a simple way to make sure they are all connected joined?
or do you have to weld individually?[/quote]

i use a plugin by Fredo6 called Curvizard… with that, you can select a segment from a curve and it will select the rest then weld them together… It also functions through groups/components so you don’t have to individually edit a group in order to weld lines within it.

if the output is that important (ie- make or break winning the job), you should probably consider using a 3rd party rendering app.

you’ll have much more control over lighting and everything else for that matter.


#8

thanks jeff i though that might be the answer just wondered if there was another route.


#9

Also screen captures and exported images will show the sketchy edges differently.

Even program performance improvements have affected images - with notable performance enhancements starting with version 7.1, I keep a version of SU7.0 around for creating animated, screen-grabbed GIFs with sketchy edges for the line quality look between scene changes.