Strange teleporting/phasing happening, can't select group

There’s no other way to say it, my group seems to be…teleporting?!
I have had this file for a while and had no problems with it. Last access seems to be a mere 3 months ago or so.

I have made some edits to the upper floors in another file and was about to import them into the main file (which is just the exterior and some interior walls) when I noticed there was still a measuring tape mark around the first floor area. When I clicked on it to erase it, This began happening!: (click this to see video)

I exited without saving thinking it might’ve been some off-chance start-up error with the file and sketchup. But every time I open the file and select the first layer…this happens!

Here’s an image to show what it looks like after a LOT of attempted moving around of this “ghost group”

But if you watched the video you can see that doesn’t even explain most of it…
What’s going on??

Here is a link to download the model from 3Dwarehouse

If you can upload your model, I’m sure someone here will figure out what is happening. Click the little icon of a bar and upward arrow in the top of the post edit window.

off the bat, i see your model has the Clipping issue. You can find out more about clipping in the forum.

Mmm says the file is too big. Gimme a sec I’ll upload to mediafire

Make sure to purge it first - sometimes a file is large due to accumulated cruft.

Oh, wow right. I dont usually work with big files so I never learned how to purge. Shall do that next time, but I already uploaded. My bad.

Built-in is Model Info->Statistics->Purge Unused. There are also various cleanup plugins.

Well, I downloaded your file and I can reproduce the behavior you see - even after purging (there is a fair amount of content that isn’t being used). As I manipulate the file, it is also causing BugSplats on my Mac. They are slowing my efforts to analyze what is wrong…

This is seeming similar to another situation I saw discussed previously in which a stair tread mysteriously moved when opened for edit. Unfortunately, I can’t find that topic (or remember which forum) right now, but I believe it was determined to be a strange bug in SketchUp that the Trimble team could see in the example but couldn’t reproduce or explain how the model got broken in that way.

I’m wondering if it is related to the material painted onto the first floor…

Mediafire fails to spit up the file.
Next time, kindly share the model via the 3D Warehouse.
Many here are willing to help you.
But few care to navigate the advertising clutter of Mediafire and other so called ‘free’ file sharing ‘billboards’.

Alright, sorry. Didin’t think to do that, first time here.
I’ll do that next time. Adding new link to original post: Click for model

I don’t get the artifacts you are seeing. Tell us about your computer, especially the graphics card.

did you try to edit the ground floor?
that’s when it all goes pear shaped on my mac…
there is something very wrong with the file, it actually freezes my whole computer if I try to edit it…

Like John, I can consistently reproduce this artifact. You need to open the large enclosing group for edit, open the first floor group for edit, and then close it. Most of the contents of the first floor move out the red axis the instant you close it. However, they appear to be a “phantom” in the sense that you can’t select them by clicking. Also, as I mentioned earlier, this model causes frequent bugsplats on my MacBookPro retina, which is quite stable on every other SketchUp model I have tested.

When I looked at this model, I noticed that exploding the group that the “phantom” came from seemed to eliminate said phantom. Very odd behavior indeed.
Not long ago, someone mentioned a need for a utility for repairing or salvaging damaged skps. I’d say this file would be a good case for such a thing.


Shep, I can duplicate your finding - good catch! This would suggest that the internal structure of the Group has somehow been corrupted.

When opened, the model performs poorly, partially due to Style settings
Turn off Profiles and view the model in Monochrome.
You’ll see lots of reversed faces … not good.

Now open Outliner and Expand All
Also open Model Info-Statistics (Therein, select Entire Model and Show Nested Components)

My guess the root of the problem is a fair amount of overzealous nesting of Groups and Components.
That, coupled with scaling Components appears to have scrambled their axes.
The use of Hide hasn’t helped either.

I think it’s beyond repair.
You might try disassembling it and saving some of the components.
Clean up those individual component files and then bring them back into a new file for reassembly.

Any object that appears more than once in the model should be a Component.
The roof tiles (a mass of identical Groups) is a good example.

one issue appears to be that groups and components have assigned materials, and are not always the same as the internal faces…
I think that this combined with the confused nesting is creating the havoc…


1 Like

In part of the video, the grouped ground floor was being moved and strange, duplicate artifacts were being displayed and jumping around. I duplicated the moving and did not experience the same artifacts on my machine. Knowing something about the computer may be useful.

The spindles have way too much geometry. Those should be replaced with lower poly components versions. Similarly, other curved profiles did not require the default number of Arc tool segments

Another simple thing to try is to make a new file and move the building into it.

If you select the problem part[s], then use Edit>Cut and immediately Edit>PasteInPlace
The issue is ameliorated.
Reset the model’s axes.
Your model needs purging - it is 200% bigger than it needs to be.
Also you have weird hidden entities in the roof hips and the the roof itself is very complex and displays artifacts on the cut-hip elements.
Many of your parts contain reversed faces - these might not be the main issue, but need fixing too…