Big bugs is here


#1

two major bugs is irritating me, first when i try to close faces, i found many faces overlap each other and i draw one line only to close the face. in sketchup 2016 i didn’t notice this bug.
second thing and this was also in sketchup 2016, whenever i try to make component or change the group to component it keep loading for forever and then i’m forced to close sketchup.


#2

Could you upload a sample skp file that shows these problems? Without one it’s hard to be sure what’s happening.


#3

the file is 100 mb


#4


please don’t purge the file, because the original file was big and i delete many items, i want you to test the file with it’s original size


#5

if you check both ramps on the 2 entrances you will find the overlapping faces and try to make any group from these faces it will hang


#6

Is this the ramp you are referring to? Notice the z-fighting (shimmering effect)? There are actually three essentially identical copies of each of the two faces in this ramp. I can delete the extra four faces with no impact other than getting rid of the z-fighting. But I can also create a Group from these essentially instantaneously, both before and after deleting the extras. So maybe you are referring to something else?


#7

how can i get rid of z fighting? and why these 3 faces produced? i just draw normal lines like i draw in all versions and the very good thing about sketchup whatever lines you draw one line only exist and one face only.i don’t know what’s happen with this version, also did you try to make component?


#8

Regarding your group/component issue, have you checked for, and installed, a graphic driver update directly from the Nvidia website? If not, do so.


#9

I think I found some of the group/component issue. With the building, the geometry is wrapped in a component. But that main component nested inside multiple group wrappers.

Try exploding some of those outer wrappers. I was able to make components after exploding the excessive group nesting. I also purged though. There’s something going on with the purged stuff interfering. Most of the stuff in that file is unused - purging drops it down to 2.56 MB. Some of that unneeded stuff is making the model behave bad.

Did you start this model by importing a CAD drawing - one with a bunch of stuff cluttering up the file?

Have you tried moving the model into a new file? You can r-click on the existing component > Save as. I was able to explode the floor plan group and save it as a component.


#10

i will tell you, this file actually is a big model but i delete many of the geometry, and i know for the purging matter and it will solve the problem because all the geometry has gone, but i want you to try without purging as you have the whole geometry inside, after many trials, uninstalling sketchup and installing again removing all the plugins nothing happen the problem is there, i can tell you with confidence that this is a bug inside sketchup even it was in 2016 and the people was asking to solve this, many complaints i see regarding this issue, i will tell something very very strange, try with the big file without purging it the following, open blank sketchup file and draw one rectangle and make a component from it once it created now go to the file again and open my file and try to make any component, it will work perfectly, try to open my sketchup file without doing this the problem is there, it means that sketchup has something weird happening when making a component in the blank file it’s like waking up the sketchup to make components in the right way. i tried this wake around many times and every time it worked, without this the bug is there, please i paid money and i purchased sketchup not to face these irritating bugs.


#11

You may have deleted a lot of geometry in the workspace, but all the components that were there before you deleted them in the workspace are still in the file - causing the excessive file size bloat. You can go to the component browser and add them back to the workspace. You have 103 components. The file has so many components, it may take several minutes for the component browser to populate. The animation below shows there are 16 different components containing the same model. You only need one. You should delete the others, they are just needlessly bloating the file.

Go through the rest of the component browser to remove the things you don’t need.

Your building component, the one with all the raw geometry is deeply nested inside 4 groups. I exploded all those groups until I got to the component.

The funky SU behavior disappeared. I could make components inside your file.

To see information about the model while exploding, do your modeling with the Entity Info window open. I like to have the Entity Info dialog alone in a floating tray. A keyboard shortcut was created to control its visibility.

There are a lot of Layers that don’t seem to be used. It seems like a CAD file was imported.

I almost forgot to mention you can study how the building component is buried by looking at the model organization in Outliner.