Groups no longer working correctly (hard to click, can't edit, etc)

MurphyVillaSitePlan.skp (4.4 MB)
Hello everyone,

I’m pretty new to CAD overall.

So I’ve been working on this file for a few days now with no problem, but just now all my grouped items seem to not be working as they should. If I go into iso view or any other camera view beside parallel, then zoom in, everything goes a bit darker as if it’s greyed out. It’s difficult to select groups by clicking, I now have to draw a selection box with my cursor over the group first to select it. And even then, I can’t double click to go into the group. Sometime it’ll work correctly again, and I’m able to go into edit group, but can’t click on the face. Or if I try to double click group, it’ll move itself to a random spot in the project space. Basically everything is just acting up.

Just before all of this happened, I installed 2 extensions (Fredo6 Extensions) for scaling and etc. I have now uninstalled them to see if that was the problem but it haven’t fix anything.

I noticed that just before the issue I also updated PhotoShop, so then I uninstalled PhotoShop but that didn’t fix anything.

I found a discussion post where somebody fixed it by correcting the tags where they tagged raw geometry. I deleted all my tags and reset everything back to Layer 0 (Untagged), but everything is still not working right!

Another thing I noticed is, if I create a new geometry and turn that into a group, that one works perfectly fine, can click, move, etc with no issue. So I suspect that only the “old” items are corrupted somehow. But I really can’t be starting from scratch and redraw everything.

Please help.
It’s 2am and I’m running out of words to search on Google. I’m not sure what to search for anymore because maybe it’s not even a “grouping” problem but something else.

Can you share your model here? We can probably figure out the problem then.

Edit: sorry. I missed seeing it at the top of your post. Downloading now…

The model has already been attached in the original post.

I see the same odd behavior as you described. Never encountered that before! Studying it to see if I can find the cause…

Did you scale something, or everything?

I did scale everything, kind of. So the reason why I installed one of the extension was for their ability to quickly scale. I used it to move everything onto one plane in one go, by selecting the whole model, activate the blue axis scale and typing in 0 to basically “flatten” everything. Then I manually selected certain groups and move those up a notch (20mm to be exact) on the blue axis, separating them from the other groups.

I can’t look at your model, but that sounds like the root of your problem.

■■■■ :confused: hopefully somebody will know how to reverse that. Thank you.

I’ve been looking at your model and trying to fix it. At this point I think it would be faster to redraw it making sure it’s all the right size to start with.

Thanks everyone. I realised that I can just go into version history and restore the file before the corruption, would’ve gone crazy if I had to redraw it.

1 Like

Not terribly difficult to redraw it. But if you’ve got an earlier version, so much the better.

I’ll stop,then.

Using “Reset scale” on any of the groups scales them down to a dot. The darkness you see is caused by z-fighting as the entities seemed to have both a top and bottom face when you scaled them down, so there are two faces on top of each other everywhere. Perhaps it would be better, as Dave says, to start again.

Reset scale! Thank you!

I suppose it’s because I’m pretty new at it, it took me what felt like forever to draw all of that.

After some further research, I see what went wrong. Instead of resetting the z coordinates of points in your groups to zero (such as is done by various “flatten” extensions), the way you did it created broken (singular) transformations for the groups. Those are confusing SketchUp’s selection and inference systems because they can’t tell where things are in 3D space. I would report this as a bug to the author of whatever extension you used. I’ll ponder it a bit more, but it isn’t clear there is a “right” way to repair the transformations.

1 Like

Good catch on the group transformations having no Z dimension

I think this file is repaired
MurphyVillaSitePlan repaired SU2017.skp (5.0 MB)

and the code used to repair the file

model = Sketchup.active_model
ents = model.entities
grps = ents.grep(Sketchup::Group)

grps.each{|grp|
  puts "Repairing #{grp}"
	trans_array = grp.transformation.to_a
	trans_array[10] = 1.0
	tr = Geom::Transformation.new(trans_array)
	grp.transformation = tr
}
p "Finished"
nil
2 Likes

Thank you! Yes at this point it’s less about repairing it (as I’ve already gone back to a previous version and worked from there) but good to understand what went wrong. Appreciate the help.

Thank you sWilliams!

Thanks for your help everyone.

1 Like