Stops responding when intersecting faces

I’ve been using SketchUp for a while now and usually everything runs smoothly or if there’s a problem I can solve it by googling solutions to similar problems that people have had. But this time I’m stuck…

What I’m trying to do is intersect a topography with a road network. The topography is taken from a DWG file, which I’ve then created a simple stepped topography from and then used the sandbox tool to make it more realistic. I did have some issues with it not working as smoothly during this process as well, but now that I’m trying to intersect the faces it seems like it’s impossible to move forward… My guess is that the geometry is to complex, but I made it work for another proposal for the area (and don’t think I’ve done anything differently) and so I need this to work for this as well!

Have tried doing it as groups, components and exploded, but nothing seems to work. Any suggestions?

The first picture shows what I was able to do with the other proposal and what I’m trying to do with the file I’ve uploaded

It’s probably not stopping. It’s probably still working. You have a lot of geometry for it to parse through so it’ll take some time. Patience is called for.

You could help speed it up by limiting the amount of geometry that is being looked at for intersecting. Turn on hidden geometry. Then select only the faces where the intersections should occur, right click on the selection and choose Intersect Faces>With Selection.

Thanks for the quick reply!

However, I tried your method and left it for 8 h, to come back and find that SU has been closed down… any other suggestions to what I might try?

Chopping the roads into smaller sections is my way of getting this working in a more timely manner. You might find you can do it in 4 or 5 pieces.

Also, instead of intersecting, you could try draping the shape of the road over top of the surface (use sandbox tools)- Once draped, this will allow you to fill the road with the dark colour. It’s not perfect either and may take some time (sometimes if your surface is too ‘softened’ then it wont work very well when you come to fill the road area…so play with softening).

Indeed, if we could work with the file, we could offer much better advice.

Most likely the file is far larger than the 3MB limit here in the forum.
Upload the file to a file sharing service like Google Drive or Dropbox
Then, post a link to the file in your reply.

Have been working on it further now, and this method works but I can only do it in VERY SMALL sections (less than 1000 entities). But at least it’s moving forward now! Thank you for your help!

Almost there now, by taking small sections at the time. Tried draping when I worked on the first proposal but it didn’t work… thanks for the help!

Seems like it’s working now, only taking quite a lot of time. Thanks anyway!

This topic was automatically closed after 186 days. New replies are no longer allowed.