Intersect faces with model blocked Sketchup Pro

Always I use the option “Intersect faces with model” my skecthup pro 2021 blocked totally. I have to use CTRL+ALT+DEL to unblock it.
Please see atached file


Any help, please?
Thank you

“Not responding” means that SketchUp is busy doing the last thing you asked it to do and won’t respond to any further commands until it’s finished. It does not mean that SketchUp has “blocked” Intersect Faces. Leave it alone and let it do what it needs to do. Looks like you’ve got a lot of geometry there for the Intersect Faces routine to look at. Be patient or do something to reduce the number of faces it needs to look at.

1 Like

Thank you. I’ll try again and let you know

It tooks 40 minutes but everything is OK. Thank you!

1 Like

Good deal. FWIW, there are strategies you can use to speed up this intersection thing. In general they all involve limiting the number of faces that SketchUp looks at for doing the intersection. I assume in your case you are trying to create a hole in the countertop to fit the sink or whatever that is. If you open the sink component for editing and turn on Hidden Geometry, you can then select only the faces in the immediate vicinity of the countertop (easiest to do if you switch to Parallel Projection and a standard edge on view) and copy those faces to the clipboard. Then open the counter top for editing and choose Edit>Paste in place. While the pasted geometry is still selected, select the top and bottom faces of the counter top, right click and choose Intersect Faces>With Selection. Then erase what isn’t the countertop.

2 Likes

UAU!
:grinning: :grinning:Thank you I’ll try it

1 Like

I have keyboard shortcuts set up for Paste in place, Show/Hide Hidden Geometry, and Hide Rest of Model which makes this all even faster.

1 Like