Stopping horizontal origin (ground) plane from taking shadows?

I have a surface below the horizontal plane with an object above which I am using to cast a shadow. (The attached is just a demonstration. In the main model I am trying out an awning over a garden so there are objects both above and below the horizontal origin plane which is set to the house floor level.)

However, the horizontal plane through the origin is taking shadows as shown. I have tried all the different ‘Default Styles’ but the only one that appears to not have a ‘hidden’ horizontal plane that takes shadows is the X-ray style which does not give a normal observer’s view. The other styles offered appear to relate to the look of the model lines and features rather than the scene.

Have I missed a setting or a style somewhere or is it not possible? I am trying to avoid moving my whole model above the ground plane (there are a lot of components) but moving the origin down could be an option if that is possible.

Demonstration Model v1 (shadow).skp (238.3 KB)

There’s not a setting to turn off Shadows on Ground in the free web version. You could just move the rectangle up above the ground plane or put it on the ground plane.

Thanks for the prompt response. I didn’t think there was a ground plane shadow setting but glad to know that I was not missing something.

Is there any way of moving the origin? Quicker and simpler than trying to move the whole model (house and garden).

You can move the origin and axes but that does not move the groundplane which is fixed.

You should be able to select all in your model and move it up in one step.

Us absolute coordinates in the move. Select all of the model, get the Move tool, grab a point that you want to be on the ground plane and start moving the selection. Let go of the mouse and type [,0] and hit Enter.

1 Like

Thanks Dave. Haven’t had a chance to do this yet but looks do-able. Will be taking a backup before I do make the move just in case.

You say that the origin and axes can be moved but that does not move the ground plane as that is fixed. Does that mean that when you start a new model the ground plane is generated coincident with the origin and red & green axes but is not locked to them? Implies that the ground plane is the only thing that is fixed in a model.

The ground plane is fixed in space. When you start a new model, the red and green axes happen to be on the ground plane. The ground plane is not determined by the location of the red and green axes. You can move the axes and change their angles relative to the ground plane and for some, that makes modeling certain things easier. If you do move the axes, it’s a good idea to reset them when you don’t need them to make sure they are where they should be.

This also has an effect on Standard Views. When the axes are in their default location, the standard front view shows the red axis going left to right and the solid green running off into the distance.

What he meant is that in SketchUp there is a difference between the “drawing axes” and the “model axes”. The former are used as references for creating geometry in the model (“drawing”). They can be moved and realigned by various methods to assist with drawing objects in an orientation you need. The latter are the absolute reference coordinates and cannot be changed. The ground plane is the red-green plane in the model axes. The fixed views (top, left, front, etc.) are also fixed to the model axes.

1 Like

Thanks for the responses - very helpful in understanding the details of how Sketch for Web works.

FWIW this isn’t unique to Sketchup for Web.

When I rotate below the ground plane to work underneath my model a layer of “fog” appears.
Any way to turn that off?

Turn off the ground in the style.

Make sure to update the style after turning it off. Click the large thumbnail to update.

OK thanks - I’m pretty weak on Styles.

It’ll come. You’ll get stronger. You just have to work out. :wink:

BTW, The thumbnail of your Style in the screen shot shows a green cylinder. The two elements are different colors. Does that indicate the two sides of any “wall” to be drawn?

The cylinder color is the back face color while the white is the front face color. This is the thing I was after you to change in your style. You have both set to the same color which, as you saw, created problems for you. The default back face color is a blue gray. I changed it to green for my template default style because I’ve worked on some computers with displays where the shaded front face color looks almost identical to the default blue back face color. I can easily pick out just a few green pixels in the display which helps me find holes. And the green is a color I wouldn’t be likely to use as a material in my models.

Yep - good thank you. Going to change it.

1 Like