Layout Ground Shadows


#1

I can’t seem to get shadows in Layout without the “ground shadow” showing as well.

I have hundreds of dynamic components referencing my origin and I am very far through a very complex model and therefore am not willing to “raise” the model above my origin point. My scene is updated with the correct settings and I still can’t figure it out. Any ideas? Thanks!


#3

Maybe this is the issue? In the shadows settings, un-check “on ground” and update the scene and save. Shadows will still operate on geometry but not on the world axis ground plane.
Also in the entity info, you can select cast and receive shadows for specific items.


#4

My apologies but I cannot share the model. I understand this makes things more difficult but I am bound by my contract…
In Layout, if my scene is set to Hybrid it shows the on ground shadow. If I render it with Raster it doesn’t show the on ground shadow but I lose my textures. Not sure if that helps.


#5

Sorry Vector doesn’t show the on ground shadow but doesn’t render correctly


#6

I think yo need to go back to the SU model and do as I mentioned above. Save the file. In Layout you will then need to select the SU item and “update the SU reference file” (right click and update or do it in file/document setup) for those changes to take effect. Then in raster or hybrid you should still get shadows but not have the shadows on the ground plane.


#7

Still looking for an answer! Thanks for the ideas whiterabbit but not what I am looking for. I assure you I have the correct check-boxes checked in my shadows window.
Can anyone tell me why the shadows in layout don’t relate to the shadows I have in my model? I installed the True North plugin to get accurate sun position and layout somehow comes up with it’s own shadows that still cast onto the “ground.” I have a detailed 3D terrain that unfortunately is below my model origin aka “ground” and the ground plane shadow blocks out the lower half of the house.
Please let me know of any ideas or if there is a better solution to get accurate shadows!


#8

It’s hard to say without seeing your specific file, but if the shadows on ground is unchecked (see attached) and the scene is “updated” to retain that information and then “re-saved” , then it should display the same way in layout?
If not (see other attachment) then you may need to check in the document setup to make sure the layout file is representing/referencing the correct SKP file. Sometimes without updating/purging etc, Layout can be showing the wrong/older version of the file?

What you describe certainly sounds like a ground plane shadow hovering above your terrain which is lower than 0,0. so if


#9

Thanks again.
In my model my shadows only show on my “physical ground” but in layout they show on both “world ground” and “physical ground”
I assure you I have the correct boxes checked with my scene updated and my model saved. I have fixed errors and purged unused in my model info statistics, my references in layout are also updated and have even been purged and re-linked. It must be a layout issue because everything in my model shows correctly.
I am now curious as to how layout renders shadows because the shadows in layout do now represent the shadows in my model which I have set up to true north.
Layout has separate settings for date and time under sketchup model, view but no option as to where shadows show.


#10

Does the viewport in LayOut show the scene as modified?


#11

Personally I would save your shadow settings in the sketchup file and have layout reference that.
If you have the shadows enabled in Layout, the shadows will fall on the “world ground plane” , which in your case would not be good.


#12

That was it! I hadn’t thought the customized viewports would cause that to happen but they did. I will have to redo the viewports now that I have shadows shown but in the long run it’s a very easy solution.


#13

Although there are things you can do to “customize” the viewports in LO, it is best practice to avoid those that make the scenes show as modified because you are disconnecting the viewport from the scene in SketchUp. Doing so means that any scene specific changes such as shadow settings and styles, don’t get shown in the viewport.


#14

Vector rendering discards all raster-based effects like shadows, textures, images, fog and “sketchy edges” styles.


#15

If it also showed us what specific setting caused it to change to show as modified, it wouldn’t cause so much confusion.
Eg. (Modified Cameraposition, Modified Style, Modified Shadowsetting etc)


#16

Yes. Or, as has been discussed before, include an option to prevent modifications in Preferences.