STL Plugin hung up at Importing Geometry


#1

I just added the STL extension. I’ve been using sketchup without problems for years and recently updated to Make 2014. I’m using an Intel 4 series graphics card with Intel 7 driver. The file I’m attempting to import is here.

I select “Import,” and “.stl,” select the file I’d like to import and make sure that all coplanar edges will merge and it will be in meters (to avoid small detail loss as the object is actually in millimeters). I see no response by sketchup when I click “Okay” other than the Edit menu offers the the option of “Undo STL Import.”

As I read around, I discovered that this problem might have happened before.

Any advice?


#2

Michael,

The STL file you linked us to requires we “Join the GrabCAD Community” to download the file.
Might you upload the file here (3MB limit) or share it on the cloud at, say, Google Drive?

-Geo


#3

Geo, thank you for such a prompt reply. Here is the file. luer.stl (26.5 KB)


#4

Hi Michael,

No joy. It does just as you describe … nothing. I tried your import settings and others.
Perhaps @ChrisFullmer can shed some light on why this STL file fails to import.

-Geo


#5

That file is a html-file with the wrong ending, maybe there’s something wrong with the download and you saved the website with the stl-filetype instead?


#6

As Cotty said, this file has HTML content and not valid STL data.

Can you try to download and upload again?

For how long? Large files might take a while.


#7

Ah, in the Ruby Console there are errors:

undefined method `*' for nil:NilClass
C:/Users/Thomas/SourceTree/sketchup-stl/src/sketchup-stl/importer.rb:215:in `block (3 levels) in stl_binary_import'
C:/Users/Thomas/SourceTree/sketchup-stl/src/sketchup-stl/importer.rb:215:in `map!'
C:/Users/Thomas/SourceTree/sketchup-stl/src/sketchup-stl/importer.rb:215:in `block (2 levels) in stl_binary_import'
C:/Users/Thomas/SourceTree/sketchup-stl/src/sketchup-stl/importer.rb:211:in `times'
C:/Users/Thomas/SourceTree/sketchup-stl/src/sketchup-stl/importer.rb:211:in `block in stl_binary_import'
C:/Users/Thomas/SourceTree/sketchup-stl/src/sketchup-stl/importer.rb:202:in `open'
C:/Users/Thomas/SourceTree/sketchup-stl/src/sketchup-stl/importer.rb:202:in `stl_binary_import'
C:/Users/Thomas/SourceTree/sketchup-stl/src/sketchup-stl/importer.rb:280:in `stl_ascii_import'
C:/Users/Thomas/SourceTree/sketchup-stl/src/sketchup-stl/importer.rb:102:in `main'
C:/Users/Thomas/SourceTree/sketchup-stl/src/sketchup-stl/importer.rb:74:in `load_file'

This is a result of the STL files not having valid data. I’ll log an issue to have better error handling: https://github.com/SketchUp/sketchup-stl/issues/142


#8

Thanks to all for the help. I apologize that the original link was to an .html that hosted the .stl I am using. In answer to one question above, I allowed an uninterrupted 8 hour period for the file to load without success.

As I understand what’s being said by @tt_su and others, the file I have is intrinsically unusable. Is that correct?


#9

8 hours - ouch. That’s way too long. If you can give us the valid STL file we can have a look.
If it opens in other software we should be able to open it as well.


#10

That is correct.

@Cotty found the problem. :thumbsup: :thumbsup:
If you change the file extension to *.txt and open with ASCII text editor (Notepad) it’s clearly HTML not STL

For your benefit I went back to GrabCAD, registered and downloaded the STL file.
Attached is the STL file, under their rather odd “original” file name, and the successful STL > SKP import.

original.stl (459.8 KB)

Luer Lock STL Import.skp (1.0 MB)

-Geo


#11

Thanks to all; you are all amazing.


#12

I am having the same problem with Sketchup Make 15.3.329 Mac, which says it is current as of 3/15/15.

I installed SketchUp STL, downloaded from here: http://extensions.sketchup.com/en/content/sketchup-stl

My .stl file is a 3D scan of my head & shoulders. It runs about 23 MB. Unless Makerbot is selling orangutans, my file surely is an .stl file, not an orangutan with .stl tacked onto the filename.

When I try to import the file to SketchUp, it hangs. Reproducible error.

Any ideas? Thanks…


#13

23 MB is not small. How long do you wait? 2 minutes, 10 minutes, an hour?


#14

Got a link to the STL file?


#15

I’ve just let it run for a couple of hours. At about the 20-munute mark, the status remark in the lower left corner of the drafting window changed to “Repairing geometry…”


#16

Thanks, yes: http://watsall.com/dist/gen/scan1.stl


#17

UPDATE !

Goodness me! Somewhere around 3-4 hours later, the file was indeed imported. The virtual bust of me is rendered huge – my head must be about 15 feet tall. Hilarious. That’s too much me!!

And fair enough, SketchUp is having trouble working with the file. And even if i shrink it, it’ll still be the same amount of geometry. What I need is a lower-res version of my imopressively huge .stl file.

So then the obvious route would be to find a utility / application that would reduce the size of the .stl file to something much smaller before trying to import it. Any ideas for such a program?


Problems importing STL files
#18

You could try Meshlab or Meshmixer.

They have different approaches to reducing polys. In Meshlab you run a filter on the model. A common polygon reducing filter is called the “quadratic edge collapse decimation” filter.

In Meshmixer you would use a polygon reducing brush and paint away the polys using the mouse.


#19

I too am having extremely long STL import times after either recent OSX upgrades or Sketchup upgrade. I am importing a simple .STL file and it is taking forever. Will link it, but this used to be instantly in the past. Im using a new 2015 MBP, 16GB RAM, plenty of processing power, etc. Something has changed somewhere along the way.

I am Importing the straight linkling in the link below, not the High Res version.


#20

What unit did you set for importing that?

I see that the mesh is very dense - at some import units the edge lengths can become smaller than the precision in SketchUp 1/1000".
I tried on Windows, using meters as import units and it imported within a few seconds.