Importing .stl files

Similar to a lot of people, I installed Sketchup-stl extention and when I try to import an .stl file, the bottom status bar keeps showing Importing Geometry while the taskmaster shows sketchup has stopped running, So I cannot import .stl files into Sketchup. I tired importing different files, with no luck.

I would really appreciate help on either using this extension or another to import .stl files.


You might be trying to import a HUGE file… try opening the file in another viewer (try MeshLab), and see how many faces the file i2… if it is in the millions, you may be in trouble.

Can you post a link to the file you are trying to import?

if the files are a reasonable size, make sure you change the import units to meters…
SU has trouble with creating tiny faces…

You can always share a link to one of those files so that others can try to import it or give more specific hints…

Hello everyone, Sorry to bother. Can you guys please help me with this? Whenever I try to import this stl file in SU, it shows the message “import failed”. Immediately after I press import. no loading or delay anything. I tried changing the stl units. Nothing worked. What can I do?
Nourfalk_3d.stl (3.9 MB)

Please do not double post.