STL file too big to import into Sketchup


I was wondering if anyone knew how to significantly reduce the size of an stl before importing it into Sketchup. The file I am using is a Blender 3D model of the city of Beirut. You can find it here (models/65 at master · forensic-architecture/models · GitHub) the download title site.blender. I would like to edit the model myself for a major project and editing is not an option in Blender as my computer cannot handle the software running. I tried exporting as an stl from Blender, but importing into Sketchup causes this:
Screen Shot 2021-06-10 at 4.25.09 pm

No progress is made and the line never moves - along with the spinning wheel on mac air. I was wondering if there was a solution to this problem. I have tried editing the model on Blender, but it is too large and I cannot even cut down the model in Blender. The file does however open perfectly well in a 3D printing software on my laptop. Thanks.

There are extensions like or that can help you here.