Can't import a large stl file

import

#1

When I import stl files, sometimes they are broken and SU tries to fix them. I don’t think it is ever successful and generally makes a bigger mess with problems that are impossible for me to find. I must resort to netfabb.
However, today I have a 24MB file that sat for over 10 minutes and never imported it b4 or after fixing it with netfabb. I tried 123D Make & Free CAD and both imported it, but I can’t export it to something SU will import.
Any suggestions on how to get this into SU?
SU make 2017


#2

well, I managed to get Design Spark to import it, then export it to an SKP file.


#3

Look under the Options button when importing STL files.
There, set the STL Units to Meters and set Geometry to Merge Coplanar Faces
Scale the model down to desired size after import.
Importing a large file takes time … patience.


#4

thanks Geo - been there done that. I import all STP files at meters.
It is a complicated model and maybe SU would do it in hours - I only let it run for about 30 min.
DS did it in minutes and can export to an SKP file. That worked.
The downloaded original STP file was broken and I had to use netfabb on it.
There was still some irregularities in it when I finally got it to an SKP file, but the STP file generated from it was manifold. I then managed to fix the other issues, which seemed like very, very slight surface distortions that created other edges that should not have been there.