Sketchup make stl import problem


#1

When importing stl files INTO sketchup they arrive 1000 times larger than their downloaded sizes. Am importing using the stl warehouse extension. I have also tried importing into Sketchup using Simlab stl importer but get the same problem.
Since the same downloaded stl files open at the correct size when imported into Netfabb this is definitely a Sketchup problem.
Any solutions would be appreciated.


#2

SketchUp can’t create ‘tiny’ faces, so importing at x1000 is a ‘good’ thing to insure the geometry is created…

once drawn inside SU, you can scale it back down as SU can handle ‘existing’ tiny faces…

both the ‘Scale’ or ‘Tape Measure’ tools can be used to resize your import…

This is best done after any modifications, for the same ‘tiny’ face issue…

john


#3

thanks john for your help.


#4

You can select the units to use when importing (see image.) STL files do not specify a unit. Most software that reads and writes .stl files assume the unit is mm. You can try to import using mm, but heed what John said. You will get better results if you import using Meters, perform any modifications, then scale down before exporting using mm as the units for compatibility with other software.


#5

One other facttoid, Netfabb sets the units in the setting drop down and the one I have shows mm.


#6

Many thanks Jim (Foltz). I had completely overlooked the ‘options’ button in the import window. With units set to mm (for objects saved in mm) my files are now opening correctly. PROBLEM SOLVED HURRAH!