SP2017 on Win7 64 bit machine prints distorted image


I am trying to print and the printed image looks totally distorted (see image). Never had that issue with SP2014 on my old CF-53, or any others before it.

This distortion

appears both when I try to export as JPG or to print as PDF, the same identical distortion. This is a brand new build of SP2017, on a new Panasonic CF-53.

Try updating the drivers for the graphics card. Intel GPUs are known to be less than good at OpenGL support and with SU2017 an adequate graphics card is essential.


I checked and the response was that the best driver was already loaded. What does not make sense is that the image I see on screen looks fine, it just does not print correctly. I might just have to dump SP 2017 and download SP 2016 while I still can.

Try updating the driver anyway. I checked mine the other day. got the same message from Windows but there were several newer drivers from nVidia.

Another thing to make sure of is that you installed SketchUp correctly using Run as administrator after right clicking on the installer. If you didn’t do that,SketchUp is not installed correctly. Failing to install it correctly can lead to all sorts of strange behavior. If you didn’t do it before, do it now. Find the installer, right click on it and choose Run as administrator. Then choose the Repair option.

Going back to SU2016 maybe the option if your graphics card isn’t up to the task. In SU2016 you can turn off Hardware Acceleration and dump the graphics processing to the CPU. That’s not an option in SU2017.

Is this happening with all your files or only this particular one?

Thanks for asking, a good question. I did a test model to see, a simple solid. It exports with the solid blacked out, and with an artifact in the skyline. See attachments.
Test model
and the original file:
Test model.skp (78.1 KB)

Curiously, SU2017 keeps on telling me “it looks like you might be offline” when I clearly am not.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.