Export 2D graphics come out looking like bad Picasso paintings


#1

So I’m trying to export linework, shadows, etc. from my sketchup model and I’ve been totally thwarted. I’ve tried exporting the 2D graphics as a JPEG, PNG, PDF but regardless of the format I choose the end result looks like a colorful crystalline mess. I’ve attached a picture for reference. Anyone know the solution? I’m out of my depth here. Thanks!


#2

There’s a likelihood that effect is due to a shortcoming in your graphics adapter or its driver - but since you didn’t fill in your user profile we can’t really tell.


#3

Try updating the graphics drivers. That may help if your graphics card is at all up to the task.


#4

if using SketchUp version 2016 (and older) you can disable “Window > Preferences > OpenGL > Use Hardware Acceleration” for fixing graphics card driver flaws - but since you didn’t fill the version in your user profile…


#5

Hey Dave! I appreciate the tip. Unfortunately, I tried updating my drivers and the latest were already installed. Do you have any other ideas?


#6

Sorry I didn’t have that info on my profile. I’m using version 2017. Is the same trick possible?


#7

No. This isn’t an option for SU2017. The graphics pipeline is different and requires a graphics card that has adequate support for OpenGL. There’s no offloading to the CPU anymore.

Perhaps you can upload the SKP file so we can take a look on the off chance that there’s something odd with the model.


#8

Gotcha. Heres the file for the model.
House.skp (1.1 MB)


#9

Definitely your system. Here’s what I get from a jpg export:


#10

I’d have to agree with Steve on this.


I expect the solution would be to replace the graphics card with something that can handle the job or maybe it’s time to treat yourself to a new computer. :smiley:

As far as your model goes, you should tend to the face orientation before you start adding materials. the blue faces are reversed and should be corrected.


#11

Ouch, that’s a bummer. A new computer was definitely not in the budget :sweat_smile: but perhaps it’s time. Thanks for all the help you guys, I really appreciate it.

Also, how does one adjust face orientation? Are you referring to the faces for the windows? Sorry - total SketchUp newbie here.


#12

What happens if you take a screenshot? Do you get the same result? I use windows snipping tool to select the area I want.

Not sure about the options in windows 7


#13

Right click on the blue faces and choose Reverse Faces. You should have only white faces exposed.


#14

I kind of jerry-rigged it by exporting to rhino, then exporting from there as a pdf. That gave me linework that I can adjust in illustrator, but I might give the snipping tool a try for the shadows. Thanks!


#15

I just thought it might get you by for a while, but by the looks of things I have to agree with the others that it’s the graphics card giving the problem.


#16

Can you be more specific about the particular Intel graphics card you have? If so, someone on the forum may be able to advise if the driver you have is actually the best one available - sometimes, even if Windows thinks it is the latest, Intel or the motherboard manufacturer may have a better one.

See [Howto] Where to find Hardware Graphics Info for your SketchUp forum profile (wiki) if you don’t see it directly.

Or, depending on your hardware (laptop, desktop?) you might be able to add a dedicated graphics card - ideally from the nVidia GeForce 10xx series - 1050, 1060 or 1070 aren’t too expensive, I understand, and cheaper than a new computer.


#17

So apparently I have both the Intel graphics card and an NVIDIA NVS 4200M, but my SketchUp is running on the Intel one. Would it help to switch which one is the default - is that even possible?


#18

Very likely it would help.

In the Control Panel you should find the nVidia control panel. Or right click in a blank space on the desktop and you should be able to open it. then you can set it to be used for SketchUp. Before you do that, check for updated drivers for the nVidia card and install them.


#19

EUREKA! We’re in business, everybody! Thank you all! Looks like this laptop has a little life in it yet.


#20

This topic was automatically closed after 91 days. New replies are no longer allowed.