Exporting 2D Images with colors and textures


#1

Colors and textures not visible when I export a 2D graphic. I have done this for years on other computers, but now it doesn’t work on a newly installed SketchUp Make.


#2

More info please. Perhaps you could share an example SKP file that exhibits this problem. It is entirely possible to export images from SketchUp with colors and textures. Why it isn’t working in your case is impossible to tell without seeing what you’re getting and what you’re working with.


#3

Sorry, DaveR, I couldn’t make head or tail out of the SketchUp tech support page. I didn’t even know if I was communicating. Thanks for responding by e-mail.
Attached is a 2D image directly from the 3D SketchUp opening format which perfectly shows the problem. I can’t get our working girl to render with colors and textures as it is in the model – they are indeed turned on. My e-mail service is not in my laptop where my SketchUp work is located, so it creates a bit of a communication problem.
I have created 2D images very successfully in SketchUp for several years, and now that I am on a different laptop and have reinstalled the program (which otherwise seems to work fine), I suddenly cannot create 2D graphics from it, which is a major need.
Best,Rich Curilla


#4

So there’s two possibilities that I can think of based on only seeing the image and not the SKP file. The first is that you have set the Face Style to Wireframe (see View>Face Styles). The other is that your computer’s graphics card is not handling OpenGL properly. That’s not unusual for the graphics card you’ve listed. You might try opening SketchUp and going to Window>Preferneces>OpenGL. Turn off Hardware Acceleration. Quit SketchUp and restart to make sure the setting change “took” and then try exporting the image again.


#5

Thanks, DaveR. I’m guessing the second suggestion is much more to the point. I know the choices between wireframe and the others and it was set correctly for textures and edge lines. When I remove the edge lines feature, I get nothing but the basic SketchUp drab green void. I will follow your procedure and see. Thanks.


#6

It worked, Dave. Your second suggestion won the day. Will I have lost any image resolution in the 2D graphic due to changing the setting?


#7

No. You can adjust the export size if you click on Options in the export window.

Turning off Hardware Acceleration means you are making your CPU do the heavy lifting. You can do searches here for hardware acceleration and also for your graphics card and read all about it.


#8

Great! Thanks, Dave. You were the help I needed. No doubt I’ll be back. LOL.


#9

Dave,
You were so kind and quick with helping me solve this same problem before that I’m hoping you can do it again – on SketchUp 2017 this time instead of 2016.
I have downloaded the free version of 2017 and already transferred two of my project files to it. Now I find that (like before) I cannot get a 2D image from it when I Export to 2D. (See my attached image dated today and taken from the SketchUp 2017 opening page). Last time on SketchUp 2016 you said, “You might try opening SketchUp and going to Window>Preferneces>OpenGL. Turn off Hardware Acceleration. Quit SketchUp and restart to make sure the setting change “took” and then try exporting the image again.” This was indeed the solution for SketchUp 2016, so I tried to do it on 2017. Unfortunately, 2017 no longer has a toggle for “Hardware Acceleration.” We seem to be going downhill with upgrades.
The second and third images are from my actual model file and switching between the only settings now available in 2017 OpenGL. The “Test 4” image is also one of these toggle selections but with the SketchUp guy again.
If this problem cannot be solved in SketchUp 2017, then I want to scrap it and continue to use 2016 (which is all I really need for the project), but my files are now locked out of 2016 since I opened them in the new one.
Solution please.
Best,Rich(bexarric)


#10

You are correct. With SketchUp 2017 there is no option to disable Hardware Acceleration. I think it was inevitable that at some point they would have to make a break from some of these older options. It can be painful but inevitable.

I don’t quite understand what you are showing with your screen shots but if your graphics card isn’t up to the task (apparently it wasn’t with SU2016, either) you’ll likely need to upgrade hardware or revert back to SU2016 and leave Hardware Acceleration disabled.

You can open those files in SU2017 and back save them to SU2016 with File>Save as… Do that and all should be fine.


#11

Thanks again, Dave.
Rich