Glitchy image when exporting 2D Image


#1

When I export from Sketchup Make I get these weird shading effects on the front of the house. The face is completely flat and only made of a single plane. The windows are separate groups which intersect through the face. The model looks fine when viewing in the program. Please help!

Many Thanks.


#2

-Check to see if there are other groups that contain faces that are overlapping the same face as the house face.

-Turn on hidden geometry to see if there’s any hidden lines distorting your material

If neither of these, upload your file to see if we can figure it out


#3

Thanks quantj, I’ve check hidden lines and for overlapping faces and that doesn’t seem to be the issue. If you have a look at this image you can see the shading issue seems to affect objects beyond the front of the house in a kind of grid pattern. This problem only occurs when shadows are turned on.


#4

Yea that’s why I ask if you could upload the file so I could look around for anything unusual. weird that the floor is glitchy too. And only when you turn shadows on, maybe graphics card issue? Is the doors in the background also glitchy? Just wondering if everything is affected or only certain materials.


#5

It seems to affect most materials but not all at the same time, by which I mean that it changes which parts of the model are affected in each export but no part is actually immune from it.

Here’s the model file, if you could have a look that would be great.
27 Bondgate, Ripon.skp (849.0 KB)


#6

I exported a 2D jpg, fine on my end, so I’m guessing graphics card.

In your preferences, check under Open GL and check what settings you got.


#7

These are the settings and graphics card I have.


#8

Looks normal, but if it’s hardware issue, that’s out of my knowledge, I’m sure someones else here will figure this out.


#9

I suspect it has something to do with how you have used layers.
There is a layer called Ground, which you have hidden. It has raw geometry on it which you should never do.
All raw geometry should be on Layer0 and only groups and components placed on other layers.
Layer0 should always be kept as the active layer.

Try removing the layer called Ground and let it’s geometry be moved to default layer, you can then group it and create a new Ground layer to put it on. Deleting the layer and remaking it just guarantees no loose geometry is left on the other layer.

It may not be the cause of this specific problem, but it can certainly be the cause of many headaches.


#10

Deselect the option Use hardware acceleration and then close SketchUp.
Then restart SketchUp and try exporting an image.

If that resolves the issue then try updating your graphics driver.
Then try exporting with HWA > ON


Updating Your Graphics Driver -— SketchUp Help


.
@landscapeman

Things to know about working with SketchUp’s layer system.
Does SketchUp Support Layers? -— SketchUp Help


#11

It is almost certainly a graphics driver issue. I also could export images without problems. One thing that also can cause artifacts like these is if your model is very large or very far from the model origin point, but this model is fully within SketchUp’s comfort zone in this respect.

Anssi


#12

Well I tried deleting the ground layer and defaulting all the entities to Layer 0 but this made no difference, however I will remember to keep all non grouped entities on Layer 0 from now on.

It turns out the issue was indeed a graphics card problem which was resolved by disabling hardware acceleration. This is odd as the drivers for the card are up to date, and I’ve never had any problems with exporting other models.


#13

I notice a portion of your “terrain” extends below SketchUp’s x,y ground plane.
Consequently you’ll want to turn off the ability of SketchUp’s ground plane to display shadows.
Window > Shadows (expanded dialog) > deselect On Ground