Something different with backups in 2019?


#1

I have it set to back up (in the folder where the file is) and auto save every 10 min but it does not seem to be doing either. I just had a crash. No backup and 20 min for the last save. (I am normally better at quick saving but when I am in a part I can zone on i forget more…) Is there a setting or something I am missing?

backupchecked


#2

I saw another thread on this topic yesterday I think. Can’t find it now though :confused: .

Personally I turn of backups and auto saves after my first 5 minutes of modeling when i hit the lag spike, never to turn it back on again, so I don’t know if anything was changed.


#3

On Windows systems, recovered files (aka, auto-save) are stored here: C:\Users\YourUserName\AppData\Local\Temp\SKETCHUP\RecoveredFiles
If you navigate to that directory, so you see any files?

When you save a model and look in the corresponding directory (default is \documents) do you see any .skb files?


#4

There is no recovered files folder. Just another Sketchup folder with my preferences an a couple other things in it.

I have been using sketchup for awhile now and 2018 has the skb files in the folder but any that I have stated in 2019 do not. And if I open them in 2019 the skb does not get updated. So no not for 2019 just 2018 and older.


#5

The Lag spike can be annoying but less so if it saves me from having to redo work because I got in the zone and forgot to quick save for awhile. Also on my smaller projects there is not spike only the largest models.


#6

I’ve gotten used to automatically press Ctrl+S whenever I stop to think, go to the bathroom, look out the window, poke my nose etc. Sometimes for very large files I automatically press Ctrl+S before starting working again when the program has become responsive just after the save has finished :stuck_out_tongue: .

That said it’s probably a good idea to keep auto save for everyone who can handle the distraction.


#7

Hi kmam,
It sounds like your expectation is that opening a file will immediately create a backup file, but that is not how backup files work.

When you save your file, the original is copied to a backup file, and then your working version of your SketchUp model is saved over top of the original.

As far as autosave… Running SketchUp on Windows, you should be seeing an autosaved file with the name of the original file (SketchUp no longer uses autosave_.skp) in the location that mchandler described above.

I hope this helps,
Susan


#8

No Autosave_File created. No skb.

In typing fast I am used to skp not skb and that is a typo sorry for the confusion.

This is my third copy of Sketchup and the only one I have had trouble with the backups. Also any backups that are hiding in documents (before files get named) are 2018 files.


#9

Yeah, I am better about it with more complicated models and later in the project but in the beginning when I am just pulling up floor plans and cutting windows I am not as good at remembering.


#10

When you installed 2019 did you do it the right way: by logging on as an ordinary user, right-clicking the SketchUp installer, and selecting “Run as Administrator”? This does not have the same effect as being logged on as an Administrator nor of running the installer without the right-click run-as. Strange and unexpected errors can result when SketchUp isn’t installed in this way. Edit: some people get away with ignoring these instructions but that seems to be a delicate matter of the exact prior configuration of your computer. Not worth the risk!

As has been written above, the actions of creating a skb backup and autosaving are independent. An skb should be created when you manually save the file, but won’t happen automatically. An auto-backup saves to a separate place using a different name that is not an skb and is usually deleted when you do a manual save.


#11

That would be the C:\Users\USERNAME\AppData\Local\SketchUp\SketchUp 2019\SketchUp

folder, mchandler is talking about the TEMP folder:

C:\Users\USERNAME\AppData\Local\Temp\SKETCHUP\RecoveredFiles


#12

They would still be skb files?

I see my CAD backups and Sketchup logs but no skb files.


#13

Incorrect. Preferences are saved in the roaming profile path …

C:\Users\%USERNAME%\AppData\Roaming\SketchUp\SketchUp 2019\SketchUp

(Temporary files are considered “local” and so the user’s TEMP directory is in the Local profile path.)


#14

Moot point though as I have checked both. :slight_smile: and no skb files anywhere except ones from 2018 and earlier.


#15

Could you try right-clicking on the SU 2019 installer exe, select Run as administrator, and then choose the Repair option?


#16

Yes that has been done.


#17

Well, the SharedPreferences are located in the local folder…:tomato::tomato:, aren’t they?
On Mac, they are in the same folder, btw, making it easier to remember! :slightly_smiling_face:


#18

NOT on MY machine.

But the PrivatePreferences.json IS in the Local AppData path.


#19

[quote=“MikeWayzovski, post:17, topic:87892”]
Well, the SharedPreferences are located in the local folder…:tomato::tomato:, aren’t they?
On Mac, they are in the same folder, btw, making it easier to remember! :slig

usually look for SKB files~ good luck!


#20

Great respect! But that is not enough when one must force quit often.