Some Shortcut Keys aren't saved


#1

I’ve modified a lot of shortcut to my own preferences and most of them work as expected, but some don’t. I’ve assigned Page Up, Page Down to Camera Views (top and bottom) and Ctrl-P to Print Preview. These shortcuts work fine in the project I’m working on until I leave SketchUp. When restart SketchUp they’re gone.

I tried Exporting and Importing Preferences and it did not help.

Is this normal?


#2

I expect you’re seeing the OS overriding the application specific shortcuts you are creating. Not sure there’s anything to be done about it, though.


#3

Good point, makes sense with Ctrl-P but not Page Up and Down, the are assigned to View Animation.

Jim


#4

Page Up and Page Down are usually assigned by the OS to the active window’s scrolling function.

SketchUp doesn’t implement scrollbars on the client area. (Although they could do this and save us the trouble of SHFT+MMB for Panning, like AutoCAD does, or at least used to.)


#5

when you re-open SU after setting the Preferences if you run

Sketchup.get_shortcuts in ‘Ruby Console’

is ‘Up’ and ‘Down’ part of the reply?

they are on a mac, i.e. they say set…

john


#6

Along with Ctrl-P for printing, but it would seem to me that SU preferences would override the OS, Page Up and Down are still available for /view/animations.


#7

I changed Page Down to Camera/View/Bottom, ran the RC command and it was there at the bottom and worked as expected. Exported Preferences, saved the file, exited SU, ran SU, ran the RC command Page Down had reverted to its previous shortcut. Opening the saved file and importing preferences did not fix the anomaly, all my other revised shortcuts are there.

Cool command, gives me a list of available shortcuts, thanks.

Jim


#8

what happens if you change the ‘View Animations’ shortcut keys first?

do they still come back and over-ride your settings?

john


#9

I just set CTRL+PgDn to Top View, CTRL+PgUp to Bottom View, and CTRL+Home to Iso View.
Seems to work well.


Ya’ need to know that “Scenes” were once called “Pages” in the SketchUp UI, so using PgUp & PgDn to scroll thru them makes sense. (Even now I usually call them “Scene Pages” to cover all possibilities, whether talking to newbies and old SketchUp users, alike. Under the hood, in the API, they are still called Pages.)


#10

Only if I exit from SU.


#11

I’m kinda stubborn, I know it will work and hold for Shift or Ctrl, it just should work as “advertised”, maybe this belongs in feature request.

Thanks for that, it explains why it does what it does, but not why we can’t change the shortcuts.


#12

Well I think it is “an issue.” As I recall, there have been several (or more,) issues raised about the Keyboard Accelerators since the v7 cycle. (I do not know why they have not yet been addressed.)

:memo:


#13

OT: in AutoCad, scrollbars can be toggled on or off in Preferences (I turned mine off as soon as the featurre was introduced). The default key for Pan is MMB without modifiers.

Anssi


#14

OT: I was referring to SketchUp’s default for Pan being SHIFT+MMB, and that in AutoCAD you can save wear on the MMB by using the scroll bars instead of the MMB.