Keyboard shortcuts don't stay


#1

When I customize keyboard shortcuts they work great, until I restart sketchup. When I restart sketchup all of my keyboard shortcut changes revert to the default. Very aggravating! I’ve tried exporting the changes, and then importing them back, but that doesn’t work either. Any ideas?? I’ve only had this problem since updating to the 2016 version.

-DN


#2

I’m having the same issue! Did you find a resolution, or does someone out there know what causes this?


#3

Most often this is caused by not installing SketchUp correctly. You must right click the installer exe and choose “Run as Administrator”. It is not sufficient to be logged on as an Administrator when you run the installer. If it is already installed, you can do the right-click and choose “repair” from the installer options.


Broken Image Links
#4

Thanks for the advice! I tried that and it didn’t solve my issue, but it did help me discover what the real issue seems to be. All of my shortcuts work except Camera/Standard Views/Top. I want to make this shortcut ctrl+p because that is what I use in another application, and I have my mouse programmed that way. For some reason Sketchup doesn’t seem to like this. Even when I re-assign the print command to a different shortcut, I cannot get it to stick after opening and closing Sketchup.

Camera/Standard Views/Top shortcut does however work if I use another key, but I really need it to work with ctrl+p.

Weird.


#5

Ah! You didn’t mention what key. Most ctrl-key combinations are preempted by Windows and can’t be used as shortcuts in Sketchup (cmd-key acts the same way on mac).


#6

yes, the deal is you can’t use keyboard shortcuts in Sketchup that are
built in defaults in the operating system. So things like ctrl+c,
ctrl+x, ctrl+v, ctrl+p, etc… won’t stay if you set them up as keyboard
shortcuts in sketchup. The fix is to use a keyboard shortcut that doesn’t
conflict with the operating system, which usually means not using the ctrl
key.

-Deron


#7

Well, that explains it. It’s a bummer because the other applications I use (namely Tekla Structures) do not have that restriction. Good to know now at least. I did not come across this in the Sketchup help documentation, maybe I missed it. It would be great if it would throw up a warning when you assign a shortcut that can’t be saved, even greater if the restriction could be removed.

Thanks for the answers, time to retrain my muscle memory!