Keyboard shortcuts not working


#1

I just loaded Sketchup on a new computer and for some reason, no keyboard shortcuts are working. Any suggestions?


#2

So none of the default keyboard shortcuts work? Maybe try a repair/reinstall?

Does the image you posted have anything to do with your question?

Please fill out your profile with the graphics card. “8mg” doesn’t help a bit.


#3

Thanks DaveR. Correct - none of the defaults work. Tried reinstall but still doesn’t work. I have no idea why that image posted, it was from an old thread. I am working on a Dell laptop with their stock Intel® HD Graphics Family graphic card. I am using a Logitech wireless keyboard, not the laptop’s, but the keyboard shortcuts don’t work on that one either.


#4

I did a complete new uninstall, new download, and install and it is now working. Thanks again DaveR


#5

You’re welcome. I don’t know that I helped but it seemed clear something didn’t get installed correctly the first time. I’m surprised that just a repair didn’t fix it. Oh well, now you can cut shorts as well as anyone.


#6

There’s an option to reset the shortcuts to default in the preferences, this helped me in this case in the past.


#7

As Cotty said, easiest way to get shortcuts working in SketchUp is: Window > Preferences > Shortcuts > Reset All (in Mac Preferences can be found from SketchUp-menu).

What I’ve seen in my SketchUp-classes, maybe one of every ten Windows machines has this problem (shortcuts not working in fresh installation). In Mac-versions I haven’t seen this problem.


#8

Hello Guys, just had the same Shortcut problem in SU 2017 after new update. And i found a good comment for 2015 version suggesting to go to “Window” >> “Preferences” >> “Shortcuts” and select “Reset All” it also dose the job for 2017 assuming also for 2016 how ever THAT made the shortcuts come back for me working fine now. hope it dose same good to you :wink: Have fun and nice drawings and constructions. !!


#9

Shortcuts not working is an anomaly that sometimes happens to me when I forget to install SketchUp as admin - that is, by right-clicking the .exe and selecting “Run as administrator.”


#11

Hello everyone, I am having the same problem with a brand new pro install, and 2nd download and install. Done all of the above and best case is, I might draw one rectangle using r and inputting dimensions before it stops working again. Any more ideas?


#12

Sometimes my spacebar shortcut doesn’t work because my location button is highlighted. 36%20PMWhen I use spacebar, it open up the location box in model info. After drawing a rectangle, it unhighlights, then I can use the space bar shortcut again. 34%20PM It reoccurs every time I start the program and I have no idea why (it didn’t used to), but it doesn’t bother me too much because it’s an easy fix. I’m not sure if this helps or not.