SketchUp 2015 Pro Keyboard Shortcuts Not Working!


#1

hello every one
my name is bandar and im from saudi arabia
it’s my first topic here … and absolutely not the last :smile: :wave:

i’m using windows 8 in macbook pro & i just start working on the sketchup 2015 pro & i couldn’t use the keyboard shortcuts for the sketch up even though it’s all in ( windows > preferences > shortcuts) but sadly it’s not working …

i couldn’t find any solution on the web so i came here asking for help

could you?


SketchUp 2016 – Oddities, Surprises, Or Bugs? (RE: Keyboard Shortcuts)
#2

I am not using Mac but can you explain a little more as to what you have tried??? More info will help others ~ does the dialogue box open for you? This is what I see from Window>Preference> on my PC

Do you get anything to select??


#3

thanks for your respond mrwmrutski
yes i can see this window and i can edit and click on everything …
but when i try to use these shortcuts it’s not working

for example: the shortcut of scale is (s) … whenever i press on (s) letter on my keyboard to use the scale it’s not working and for everything else too
as long as it a short cut
but it’s working just fine when i press the icon of scale

i hope i explained what happening with my sketch up very clearly

please help the progress without shortcuts it’s very slow


#4

Hello and it sounds like a setting issue of Mac itself, I know little of Mac anything. I was bottle feed on a PC but will pass this along to a individual I know uses both operating systems and should have insight or the answer.
From seeing other posts Mac has some different settings that need to be changed and this may be one of those. And yes it does stink without the hot keys… I started to learn SU on a laptop without a mouse only the built-in touch pad // click options. After two days may hand hurt so bad and the amount of time to complete anything. Hang tight and I will copy/paste your explanation to him…Peace…


#5

Press the reset all button and it should work though you’ll loose all your custom shortcuts. I’ve seen a lot of Macs with that problem but also on some windows versions.

If you have a prior version of SU with all shortcuts set you could use the export button from it and then import from your current version. That should also work…


#6

COOL and thank for the Intel, I will pass it along!! It is hard enough learning the functions then adding something like this really makes it worse. You feel nothing you do works,thanks again and …Peace…


#8

QL
6m
mrwmrutski

Press the reset all button and it should work though you’ll loose all your custom shortcuts. I’ve seen a lot of Macs with that problem but also on some windows versions.

If you have a prior version of SU with all shortcuts set you could use the export button from it and then import from your current version. That should also work…

This was just passed along and give it a go. Hopefully it does the trick for you…it is hard enough with curve balls being thrown at you also. Good luck and …Peace…


#9

thanks both of you mrwmrutski & JQL
its so kind of you

i reset all the shotcuts then closed the sketch up & open it again
and now every one of them working very well …thanks guys


#10

COOL BEANS…!! Good Luck with it…


#11

Hey mrwmrutski…
Thnx alot…It worked :grinning:


#12

Yes me to notice i have remove the ctrl + V and added that command to paste in place it work fine when sketchup is open. once restart sketchup the shortcut disappear and default ctrl+V shortcut is set.


#13

Ctrl-V is a default Windows keyboard shortcut. You need to use a different shortcut for Paste in place.


#14

but to paste have 2 shortcut ctrl+v and shift+insert so i remove ctrl+v key when added key it works perfect after restart it been removed


#15

many users here use shift + v for paste in place…


#16

You aren’t making a permanent change to Windows so of course the keyboard shortcut isn’t going to stay set.


#17

i have a same problem. On mac os hotkeys are not working. Program version Sketchup make 2017. CMD+0 against P for push/pull operation, but in preferences -> shortcuts binded P