Make2017 keeps resetting custom shortcut. Why T_T

make
shortcuts

#1

Hello cozins!

Having a quirky, but hella annoying little problem with keyboard shortcuts in Sketchup Make 2017. Wonder if anyone knows what’s going on:

I want to assign a command Ctrl+Shft+E to [Edit->Unhide All]. That particular command is taken by the [Camera->Zoom Extents]. Sketchup tells me this, I click ok, and reassign the shortcut. It works great – but for that session only.

Next time I open the program, that shortcut is reset back to Camera Zoom Extents! Every. Single. Time. Does it think I wasn’t serious? XD And seems like it’s just that particular command for some reason, because I’ve assigned custom shortcuts to other functions and they work just fine.

Why does the program keep resetting that shortcut? How can I make it “remember” that I reassigned it?

Sure hope there’s an easy explanation… XD Thank you!


#2

Hello. This happens usually with hardcoded shortcuts like Ctrl+P for Print, Ctrl+S for Save. However you change them, when you restart SketchUp, they go back to defaults. But Ctrl+Shif+E is not a hardcoded combination as far as I’m aware of. Did you have this problem in earlier versions?


#3

Is SHIFT+Z the default zoom extents shortcut ?

I also have CTRL+SHIFT+E set to zoom extents (in SU2016) and it works and is persistent.


Just a thought, if any error occurs and SketchUp crashes any settings changes made will not get written to the registry (or plist on Mac.) So after making any settings changes, close and restart SketchUp.


#4

Problems with making shortcut changes have been reported before.
They were sometimes associated with an improper initial installation of SketchUp.
The only correct way to install SketchUp is to select the installer exe file’s icon, right-click > context-menu > Run as administrator…
Doing it any other way - e.g. by double-clicking the icon - can result in all kinds of unexpected flakiness - even if you are the admin or have admin-powers it is not the same as doing it by 'Run as administrator’
You probably don’t need to do a full uninstall/reinstall.
Firstly try this: close SketchUp, find the installer exe file, or download a new one, Run as administrator - when prompted choose Repair…
Retest to see if that has resolved your issue ?
If not then repeat the process but this time choose to uninstall, then immediately repeat the installer again and install afresh…
Any better ?
Uninstalling should not affect any of your Plugins etc, but shortcuts [if any] can be affected…


#5

This did happen to me in earlier versions!

I wish the program would specify which shortcuts are hard coded and cannot be changed. :frowning: Woulda saved me a lot of grief over the years.

I ended up assigning Ctrl+Alt+E, and that one took.


#6

TIG, thank you so much for the useful info. Running Repair did not resolve the issue, and I don’t want to do a full reinstall for one shortcut. (That may or may not work.)

But I’ll keep in mind ‘Run as administrator’ installs for the future! Wasn’t aware it made such a difference.


#7

This topic was automatically closed after 91 days. New replies are no longer allowed.