Some of my walls are transparent - others are solid. Why?!


#1

Hello! Newbie question but would love some help with making all the walls in my design solid. They were previously but now some are transparent and others solid. Thanks!

Roz


#2

There could be any number of reasons.
Can you attach the model or at least an Image.


#3

Thanks Box - here’s an image


#4

At a guess I would say you have probably painted the walls with the material you used for the glass in your windows.


#5

It’s not clear to me that there’s a face there at all. Can you select the transparent wall?

Shep


#6

Yes, the faces seem to be deleted, thus not selectable at all. That would be my guess too.


#7

When I first drew the walls and the windows the colours/materials were the same on all three sides - no issues at all. I’ve just redrawn the problematic walls and although the colour isn’t transparent anymore it won’t colour the same shade indicating there is still an issue. Are there any settings I might have adjusted which means when I draw faces the material is transparent?


#8

Yes Shep and Wo3DAn I can select the wall.


#9

Then I’d say @Box has your answer.
See what happens when you repaint the transparent wall with some other color.


#10

I agree with @Box that the likely cause is that you have painted the outside surfaces of those walls with a translucent material. I can’t tell from the picture whether that is the SketchUp front or back of those particular Faces, but be aware that you can separately paint the two surfaces with different materials! Also, if the walls are components or groups, you may have painted the entire group with one material but while open for edit, painted faces with different materials. If you do this, the per-face materials will dominate over the one on the exterior of the group. You have to open the group for edit again to alter the materials inside.

If you had uploaded your model, we wouldn’t have to guess!