Model Walls Transparant


#1

Hi All
Fairly new to sketchup and in particular rendering using Twilight.

Im hoping someone can help? Ive been modelling my new house build and everything seemed ok until I started rendering various scenes. I first started to notice window frames becoming transparent, and took a lot of effort to put it right. Now that Ive moved back to en-suite to finish off the modelling I have noticed a big chunk of my house model has now become transparent. It maybe that Ive done something tragic from the beginning and may have to start all over but im hoping not?

Please note that my model isnt finished, but any advice anyone may have would be greatly appreciated. My model can be accessed from the link below

https://drive.google.com/file/d/1X8r3dj0f0ROeKda0EjL6yI7xSPMbqR3L/view?usp=sharing

Rgds
Richard


#2

In your model I would select the “monochrome” option under “styles” (far right). This will show you all of your faces, whether transparent or not, and if they are reversed or not (important for the renderer). This should help you determine if you are looking at an actual face that is transparent or if there’s nothing there at all. I would reverse the faces as needed and then in materials, use the eye dropper tool to sample the materials that exhibit transparency, when you go into the edit mode of the texture you can adjust the transparency on the slider, as some of your materials (other than glass) may of become transparent by accident. Note that the two sides of a face can each have different materials too.
Sometimes for an interior room scene I will make the exterior walls transparent so while looking in/orbiting from the outside I can see what’s going on, but when inside of the room, looking at the reversed face the solid textures applied to that appear normal.


#3

Hi White Rabbit
You nailed it! It appears that possibly when I was making my glass on gable end transparent it also included some of the partitions fixtures and fittings as well by mistake. Slid the opaque slider back to the right now all ok

Thanks for your help
R


#4

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.