Interior wall not supposed to be reflective

I’m new to SketchUp Pro 2017 and I was rendering this bedroom using Twilight Render, and I noticed that the wall with the three paintings reflected whatever was in front of it like it was a mirror, when in fact the material and texture is only a solid color. Is this supposed to happen? If not, how do I fix it? Also, rendering this part of the model takes an awfully long time. Thank you in advance.

Check all the settings for the wall material in Twilight. It has probably mirror-like reflections turned on.

How do I do that? These are my settings for that particular wall:


I am sorry but I don’t use Twilight. I would know how to do this in V-Ray, ArtLantis or a couple of old render engines that have already passed away. What other choices do you have than “SketchUp” in the popup menu? What does “Blended clip” do?