Some imported geometry is extremely far from the model origin

Hello, I’m having a problem with my plan view model that I import from Autocad coming in way too large. I get the following message when I import the model.

“Some imported geometry is extremely far from the
model origin. If you experience any instability with
your SketchUp model, please delete that geometry
from your .dwg/.dxf file and import again.”

The bounding box around my model is much bigger than the model itself. I think this is causing issues with the orbit tool. When I use the orbit tool, the view changes are extreme and clunky. How do I fix the problem?

huge model.skp (914.9 KB)

old Hospital plan error.dwg (512.9 KB)

huge model fixed.skp (954.3 KB)

I use the extension that came out of this discussion:

There is two restaurant tables on the top right corner of the main component, that is why bounding box is too large… If you turn on the junk layer, you will see a line too… I suggest you to explode the component, choose the pieces necessary and make group… Then select all with ctrl+A and deselect the main group and hit delete key…

Thanks a lot. That corrects the issue.