Some Geo-location Terrain not loading

Terrain appears and disappears as I zoom in or out, grab and drag map. Not sure if it’s the graphics driver, slow internet, google maps, or sketchup. Screenshot shows the problem.

Please advise,

This is what I see.

@colin was helping someone yesterday with a similar thing. Not sure if he got it resolved. Clearly the information is there to get.

Thank you for replying.

That eliminates the google map portion. It just started yesterday and I let it set for a few hours to see if it loaded. I tried watching a movie on hulu, on my TV and it kept reloading and said there wasn’t enough…memory? I think and I had to change settings. So maybe internet.

None of it comes from Google. You might try clearing caches and temporary files.

Thanks DaveR! Could slow internet possibly be a cause.

Ok, I’ll give that a try.

I suppose slow internet could be a problem. I’d try cleaning things up first–quit SketchUp and anything else running. Then a power off reboot won’t hurt.

I cleared all search history, cookies, cache. I went directly to google maps and location loads and operates just fine. Tried Geo-location again through Sketchup and still same problem. Some terrain missing at zoom 15 and entire terrain missing at zoom 18. UGH! So puzzling.

Strange. I get this:

Kemp.skp (2.7 MB)

I wish I did too, lol. Haven’t had this issue before. I’m gonna try calling internet provider to run a system check, at least to eliminate that cause also.

1 Like

The issue isn’t anything on your computer, it’s a problem with the provider of the tiles. If you are interested you can right-click and Show Dev Tools, then look in the console for errors. I’m fairly sure you will see 503 errors, which is a permissions issue. Don’t know why you are getting them at the moment and we’re not, but you are most likely going through different networks than us.

Did you try at 16x or higher? If you can get any zoom level that has filled in tiles, it will import ok, so long as you keep the import level the same (if you see that feature). If you can get any zoom level imported you can the use the Add Imagery option to add on adjacent areas.

A side benefit of having to do more higher zoom level imports is that the terrain will be a lot better.

Thank you Colin, I will definitely give that a try and repost the results.

So when I right click on the empty box/tile and choose Dev Tools, I get the info attached. What am I looking for? Any higher than 15 and I get no terrain.

These are all of the tabs in Dev Tools. See anything that might be the problem?

William Moore

This seems to be the possible problem to the missing terrain. Next step anyone?


That was a lot of screenshots. Mostly those should be warnings, not the errors I was expecting. When I’ve had missing tiles I would also get an error (that would be in red in Console).

I will see if I can get more people to drop by here.

Sorry about all the screen shots. Thanks for looking into it for me.