(SOLVED?) Sketchup Make 2017 Freezes at startup with Graphics card


#1

When I try to run sketchup with my Nvidia GTX 960M graphics card it freezes on launch (Not Responding)
Runs fine with integrated graphics.
I have updated my graphics card drivers to most current version.
Any fix?

WIndows 10 64bit


#2

In your GC control-panel is it set up to let the 3d application to choose its settings [like SketchUp should be] ?


#3

I changed everything that I could to “application controlled” setting… still freezes at startup


#4

Any installed plugins?

Where did you get your driver - directly from Nvidia?

Sometimes older drivers work better. You can always rollback drivers via the Device Manager if the latest install doesn’t work well. Control Panel > Device Manager > open display adapters > r-click on card > Properties > Driver > Roll back driver > OK.

You did install SU via r-click on installer > Run as administrator?


#5

There are no plugins other than than what came in the installation pack… I tried removing that folder and no change. I did get the driver directly from Nvidia’s GeForce Experience. I did try uninstalling and installing via Run as Administrator.

will try the driver rollback


#6

Driver rollback didn’t help


#7

In the Nvidia control pane 3D application settings, have you checked that SketchUp is set to use the Nvidia card? This is how I have it set up ( your graphics card is a speed monster compared to mine):

Automatic selection does not work here. Windows directs automatic display driver selection to use integrated graphics.

I don’t know how many times I have posted these images…

Anssi


#8

Yes, I have set the program settings for Trimble Sketchup to run with the (High-performance NVIDIA proessor) and that is when it doesn’t work…it does run with the integrated graphics on my i7-4720HQ CPU.
I can run and use sketchup on my PC… just not with my NVIDIA GTX 960M …


#9

Grrr…

Do you have any 3rd-party plugins/extensions installed? Ruby environment changed. Quite a few plugins need to be updated to work.


#10

Didn’t install anything but Sketchup Make 2017…no plugins.


#11

Had the same problem with Sketchup 2016


#12

Downloaded and ran Sketchup Checker and it passed all tests… but Sketchup doesn’t run (With my GTX 960M)


#13

With SU attempting to run, see if you can view active, running process through your antivirus program (I can r-click on it’s icon in my taskbar > Control active processes.) Is your antivirus program trying to block SU?


#14

Same problem without any antivirus software running… I doubt that could have anything to do with it anyways as SU opens and runs just fine with my integrated graphics… it’s only when I try to run with my NVIDIA 960M that the issue rises. The program looks like it is loading up but as soon as I try to click anything it goes (not responding)


#15

Doesn’t hurt to rule it out. SU has been alienating my antiviral program for years.

Trying to run SU17 in a clean boot state limits background processes while still being able to use the Nvidia driver. It’s an isolating troubleshooting state that easy to set up and then restore normal mode with a checked box and restart.


#16

Let’s step-back a few paces…

Can you close SketchUp, then reinstall it.
Find the installer exe icon [or re-download it, then find it].
Select it and right-click > context-menu >
Run as administrator…
When prompted choose to ‘Repair’ the installation…
Afterwards try SketchUp again…

It is NOT sufficient that you might have full admin powers as a user - it MUST be installed using the exact method outlined above.

If that approach fails, then you could try a full uninstall - followed by a fresh ‘Run as administrator…’ installation…


#17

teddy: shot in dark but, you when getting the not responding note see if you can start task manager, down at bottom of page look for resource monitor, select that , make sure you have the processes tab sleeted at top of page, check the running processes and note if any are showing red. Some times things freeze because one step needs to be performed before another can start. Any showing red you can run a wait chain analysis and see if it is waiting on some thing to finish. Hel will tell how to set that up. Long shot but ??


#18

Uninstall/reinstall > r-click run as administrator was done in post 4. Intel graphics chipset runs SU fine.


#19

[quote=“catamountain, post:18, topic:34322”]
Uninstall/reinstall > r-click run as administrator was done in post 4.
[/quote] BUT the OP never said he had done it !
Just backtracking to where perhaps the balls-up began…


#20

Catamountain,
I tried the clean boot and was able to run SU with my Nvidia GPU… still not sure what was causing it tho… have re-enable all services and a few of the startup programs(there’s about 18 startups that I left disabled because they’re unnecessary)

So, now that I have it running on the Nvidia card… I see no noticeable difference in performance. everything is pretty smooth til I view in Walk mode… then things display at a low frame-rate when moving around.
Is this normal or should it be nice and smooth? It’s bad enough to almost make me dizzy