Sketchup Make 2017 Freezes Regularly

I have a powerful PC, and have worked on models with many tens of thousands of elements. However in the last 5 weeks, it freezes for about 10 seconds, and does this about every minute. Is making it impossible to use. I have tried a “run as admin” repair process, and that didn’t help.

Anything happened recently? incompatible windows update or something?

Of course there’ve been no changes to SketchUp 2017 so you do need to look at what has changed. There have been some Windows updates that have created problems and there may have been a graphics driver update included in a Windows update that is responsible. Make sure the graphics duties for SketchUp are being handled by the Radeon GPU and that it’s drivers are up to date. Check with the manufacturer on that. Don’t trust Windows to tell you.

Where are you saving files to?

Hi, fast response!

Saving files to local ssd. How do I know they are being handled by Radeon? I would assume they must be, as all the monitors are plugged into the Radeon card. I’ll check for updated drivers on AMD now.

Thanks.

In SketchUp’s Preferences go to OpenGL and check.

  • SketchUp has detected you are using a “Intel® HD Graphics 4000” graphics card when your system is capable of using an AMD or NVIDIA graphics card. SketchUp will likely perform better if you change your system to use the AMD or NVIDIA card…" I’ll try updating the drivers, although that tends to be a pain with AMD…

It sounds like a Windows update probably set the integrated Intel GPU as the default. We seen that sort of thing before.

even though my monitors are plugged into the Radeon… that seems rather odd!

Yes it does, doesn’t it?

Right, found out something. I have 3 monitors plugged into R9 and one plugged into MB. Is there a way to determine which card is used, as I don’t have it displayed on the screen connected to MB…

The suggestions from searching are to select from graphics settings, which card will be used. However… only the Intel one appears, under both power saving and hi performance… These settings and methods to select GPU for an application seem pretty messed up…

Normally you would use the graphic card’s control panel to set this. The machine I am using right now has an Nvidia graphics card and its control panel looks like this:

Yes, I am pretty sure that the Nvidia is better than AMD, and would have been much better for Adobe premier too!

So what worked, was changing the “primary monitor”, to a monitor plugged into the R9.

Given it doesn’t do anything that I can see, other than determine where the start button is, it seems a bit odd.

Now under windows settings for graphics, both high performance and low power options show the R9 and now Intel…

Thanks for all your help, you got me to the initial diagnosis super fast!

1 Like

Agreed. If you do a search for graphics related problems, you’ll see that there is rarely ever a problem reported with Nvidia GeForce or the GTX-series cards. I’ve had Nvidia cards in all of my computers since I started using SketchUp in early 2003 and I’ve never experienced any of the graphics problems I’ve seen reported. Statisitically that’s a pretty small sample size but it’s enough for me to not want any other GPUs in my computers.

Good luck as you proceed.

1 Like