Solid Tools Subtract not working

I have to solids - I am making a “key” for two model pieces to fit together once printed. When I use Union to adhere th male key to the body, everything works as it should. However when I fly the key around and try to subtract it from my model and make the female half of the key, the key just vanishes. I can use any other solid tool and it works as expected. I have used subtract in this same model and it has also worked. Why not this one piece?

It’s suppose to vanish when you use Subtract. Use Trim instead of you don’t want to lose the object.

Share the .skp file.

It’s not supposed to vanish and leave nothing behind. It’s supposed to subject its own shape from the second shape. See in picture three how it’s simply gone and there is a flat surface left behind?

I’ve been using SketchUp since long before the Solid Tools were introduced. I know how they are supposed to work. The first object selected is subtracted from the second and is deleted in the process.

If you aren’t getting a similar result, there’s something amiss with your workflow. As I wrote, share your SketchUp model.

By the way, your profile says you are using SketchUp Free (web). That version doesn’t include the Solid Tools. What version are you actually using?

If it is not removing anything from the second solid there is likely a problem with something… how big is your model? Is it possible the hole would have faces with edges smaller than .001”?

If you don’t share your model as Dave requested it’s gonna be difficult to help you solve this issue.

Hi Aaron I saw your video on drilling holes through pipes. The pipe I need to drill a hole in is a component. In the entity information it states this - using the subtract tool it identifies as a solid. However, it only identifies as a solid if you click “Edit component” otherwise it says it is not a solid. The rod I need to drill through the pipe to create a hole is a solid no matter whether it is being edited or not. As a result, if you need the pipe to become a solid, you have to “Edit Component”. When you do this, the rod is greyed out. If you go out of the edit menu, the rod remains a solid but the pipe now becomes “not a solid”. No matter what one does this remains the case so the simple act of putting a hole in a pipe is not possible. I would appreciate your comments…

This implies that the pipe is a nested component. That is, a group or component within a component. Explode the top level component so that your pipe and the drill are in the same context.

Parent components/groups cannot be solid.

It would be easier to help you specifically if you share the model file.

Thanks Dave - you are correct that it was nested… I have resolved this and successfully drilled 2 out of 4 holes by putting the rod through the pipe. To get the next 2 holes I have turned the “drilling rod” through 90 degrees and tried using the same Subtract function - but it just results in the pipe disappearing completely… see attached file

Looks like I have solved it… just have to work out how…!

Probably selection order. Since you are using the native Solid Tools, say the following as you use the tool. “Subtract this from that.” or “Use this to Trim that.”

BTW, your forum profile says you are using SketchUp 2017 Make. The solid tools aren’t available in that version. Please correct your profile.

I’m using Sketchup Pro 2023 – I tried removing the Free Sketchup 2017 from my profile but it refuses to go – I can remove the Pro version, but not the Free version… tried for 30 mins and couldn’t do it…

If you go to your Profile under Preferences you can edit the fields. These are mine:
Screenshot - 10_16_2023 , 5_31_51 PM

Then scroll to the bottom of the page and click Save Changes.
Screenshot - 10_16_2023 , 5_32_03 PM