Subtracting one solid object from another results in a non-solid object


#1

Well, the subject line says it all. I have two solid objects. When I subtract the white one from the green one, the resultant object is not a solid, but it should be. I would like to subtract another portion from it, so I need to retain that property.sketchup_bug.skp (451.5 KB)

Let me also say that I’m running the free version of Sketchup in Linux via Wine. I can’t imagine that this is an issue with Wine; computational geometry is highly OS agnostic.

The version I’m running is 16.0.19911, 32-bit.

Thanks for any help.


#2

Just scale the whole thing up by a factor of ten. Do the subtraction and rescale.

Shep


#3

As Shep says, scale up before running the tool. Otherwise you run into a tolerance issue.

It’s worth noting that the Subtract tool in the Solid Tools set will convert the component getting modified into a group. If you don’t want the component converted to a group, you can use the Subtract tool from Eneroth Solid Tools available in the EW. It keeps the component a component and all other instances of the component will get edited the same way. This means you can scale a copy of the component up, make the subtraction and then delete the scaled copy leaving the original where you drew it.

I notice you are referring to the Subtract tool but you say you’re using the free version of SketchUp. Are you actually running the 30-day trial of SketchUp Pro? The Solid Tools are only available with the pro version. And Eneroth Solid Tools only work in pro, too, because they rely on the Solid Tools.


#4

I see that I am running the 30 day pro free trial. I didn’t intend to do so, as I can’t possibly afford the pro version’s price. So, I guess I need to find a way to do this without boolean operations, or just skip this detail.

Thanks a lot for the help.


#5

On a side note, how do I disable the free trial pro features? I don’t want to make a model that I discover after 23 more days I can no longer edit.


#6

It’s not hard at all to do that without the Solid Tools. Explode the cutter. It doesn’t want to be a component for this. Then select all of its geometry. Hit Edit>Cut. Then open the green component for editing. Hit Edit>Paste in place. Select all of the geometry of the cutter and the green stuff. Right click and choose Intersect Faces>With Selection. Erase the geometry you don’t need leaving the trimmed green part. If you don’t put the “cutter” inside the component, you won’t have the mitered surface when you get done.

There’s no need to disable the pro trial. You will still be able to edit models you’ve created with it after it switches to the free version.


#7

You could just use the follow me tool.