Solid Tool Problems

I’m having an odd problem in using the solid tool Subtract. If I try and remove this ring from this block (both groups), one of two things happens. Either the ring disappears and there’s no groove in the block (which is what the result should be), or the ring’s faces reverse and there is no subtraction.

I’ve tried “isolating” the block and ring by copying and pasting them to a new project:
SolidTools.skp (197.3 KB)
However, the problem seems to follow them. This is very concerning.
I tried opening a new project and trying it with new shapes, a cylinder subtracted from a block, and the result was a block with a cylindrical section removed, as it should be. I’ve restarted my work PC (Windows 10), but the problem remains. I’ve uploaded the “isolated” version of the project and I’m curious if anyone else is going to have the same problem subtracting the ring from the block.

I can’t look at it right now but try scaling the model up by 100 or 1000 and run the tool again.

I just tried again after exploding the group and re-grouping them. It didn’t work, but I gave the un/grouping one more try, and now it’s working without issue. I’m still curious to see how the “isolated” file works on someone else’s desktop, if this was simply a fluke or if, like I said, something followed those shapes to another file.

Update: I scaled up the Isolation file’s model by a factor of 10 and subtracted the ring without incident. After undoing it, I scaled it back down and tried again. The ring disappeared, no groove in the block. This is odd because technically it’s already scaled up. The block is 36cm wide. That’s typically not a problem for the geometry, so I’m not sure what’s so special about these particular shapes.

It worked ok for me when I scaled it up x100

Interesting. I must have hit some kind of threshold for complexity and scale. It’s odd because I’ve modeled items like this with similar dimensions before with no problems.

It’s the little edges on the ring - if any of those get intersected then they will be even smaller

Funnily enough, if you left the ring up just a tiny amount, even 0.01mm.It works.

it’s always glitchy on small things

1 Like

What are you modeling and how are you planning to use it?

The ring is to make a groove for an o-ring so a car part can be mounted in a tester. I typically work at 10x scale because SketchUp has such a problem with small geometry, so I scale them down before they go into the slicer for 3D printing.

You’ve surely seen other posts I’ve made about what I find useful when modeling for 3D printing. I model with units set to Meters and treat them as millimeters. Exporting the .stl with the export units set to Model Units and import into the slicer in millimeters. No need to scale up and down at all. This avoids the tiny faces issue entirely.


Click in sequence on the scenes tabs of this SU file for ideas.

SolidTools - 2024-03-19 - JL.skp (496.0 KB)

Listen to the wisdom of DaveR. Make your 3D printing template in meters, never scale a thing and never have another tiny face issue again. I keep waiting for SU to just make a switch in preferences to effect this under the hood, as in “turn on tiny face mode”. But for now this is by far the easiest set it and forget it method of working on small precise things.

1 Like