Sketchy solid subtraction

(Sketchup Pro 2021 desktop)

Hello community,
I ran into this issue multiple times before but never bothered asking or reporting on it, but now that I have a bit more time I thought I’d finally ask.
As you can see in the gif screen capture below, I subtract a small cylinder solid from my main model solid. It worked fine on the right side of the model but doesn’t on the left side. The result is that the entire model is deleted and the cylinder gets inverted instead.
(Solid Inspector report zero defects)

Obvious questions: Why is this happening? What am I doing wrong? Is this a known issue? Is my model too complex for solid operations?

40mm fan adapter Mosquito.skp (258.6 KB)

How about sharing the model so we can take a look?

What version of SketchUp are you actually using? Your profile says you are using the Free web version which doesn’t have the Solid Tools. The toolbar visible in your GIF is also not from the web version.

I don’t come here often so I hadn’t updated my profile in a while.
I use the 2021 Pro subscription version.
I just added the .skp file for download.
Thanks!

Thanks for updating your profile.

You are running into the tiny face issue. Since you are using groups in your model, I scaled the whole thing up by a 1000x and then successfully subtracted to get the counterbore. If you use components instead of groups you could do this using the Dave Method.

How do you plan to use the model? Is this for 3D printing?

It looks like there’s a lot of unneeded triangulation in your large group. I expect if you were to clean that stuff up first, your model would be easier to work with.

Yep, 3D printing. Got it from Thingyverse, hence the quality.
I’m in the process of cleaning it up and adapting it for my need.

That’s a neat trick I didn’t know.
Thanks a bunch! I learned something! :+1: :+1: :+1:

I think I would start over. In fact I’m in the process of trying to model it from scratch. The problem with using files from Thingiverse is they generally need a whole lot of fixing. I’m finding strange dimensions that don’t really make sense. The large part of this thing measure 40mm in one direction and 39.99992mm in the other direction. Not a huge difference in reality but enough to create problems later.

BTW, if your slicer software will allow you to select the import units, you could create the model in meters and leave it that size, export the .stl using Meters and import using millimeters.

1 Like

Is that flat on the side of the smaller hole necessary?

Flat side not really needed, I guess.
Yes, the dimensions are shiite. I don’t understand how Fusion360 always manages to mess up exports like that.
I was hoping to fix this model quickly. It’s not a critical part and the original unmodified version printed good enough. It only needed a longer “neck” and wider counterbores.

I’ve already added the flat so that’ll stay, I guess. Are there only two holes? Or should there be four?

2 only.
I appreciate your help but you don’t have to do it for me. :sweat_smile:

I know but I still had to do it. :smiley:

Mine is on the right.

Here uploaded to i.Materialise. I use that site to check .stl files as I don’t have a slicer installed on this computer.

See if this will work for you.
40mm fan adapter Mosquito dr.skp (146.2 KB)

1 Like

Wow man, unbelievable! You’re lightning fast too!
Thanks a bunch!

Thanks. And you’re quite welcome.

Turn on the hidden geometry in both files and compare. I used more segments for the sides in the holes and counterbores–maybe more than needed for those but mainly look at the geometry in the large hole.

1 Like