Soften / Smooth Edges not working

On the web, I select surfaces to smooth, right click ‘soften/smooth edges’. Nothing happens.

What am I doing wrong?

I’ve used this feature on sketchup make 2017 but since it’s no longer supported I’ve been trying the web version.

hmmm careful, you smoothen the lines, not the surfaces themselves.

If you only select surfaces, it won’t smoothen them.

I’ve included a screenshot…

I’ve basically been trying for hours to work out a way to have a smooth transition on those inner edges…

1 Like

Please post the model so there is no guessing.

Keeper Limiter 2.skp (122.0 KB)

Here you go attached…

Do you have the edges selected when you are trying to soften them? The softening angle has to be quite large. If you’re 3D printing this thing softening those edges in SketchUp won’t make the surfaces smoother. To do that you would need to use more and smaller faces.

Keeper Limiter 2.skp (139.0 KB)

Smoother surfaces in this one.
Keeper Limiter 2.2.skp (133.6 KB)

Click in sequence on the scenes tabs of this SU file for ideas.

Keeper Limiter 2 - JL.skp (241.6 KB)

I have the same problem. Selecting “Soften/Smooth” from the context-menu (right-click) doesn’t do anything.
Also, the settings window for Soften/Smooth (with the slider for Angle between Normals) doesn’t show up at all.

Thanks for taking the time to produce the file with all the pointers - much appreciated. As you can see, I’m very out of practice with sketchup in general.

From what I can tell the sandbox tool isn’t supported in the web interface, which is what I’ve decided to try here, is that right? You mention the ‘reverse edges’ in your file. From my screen grab it looks as though I had alternate faces/triangles reversed - is that what you were referring to? Are reverse edges a different thing versus reversed surfaces?

I can see you effectively inverted the triangle arrangement I created down those curved sides. How did you know this would create a more favourable gradient? It wouldn’t have occurred to me.

So after reading your comments within the file you produced for me, I went back and tried to apply your suggestions to my original file so I could learn from it. First of course I removed all that mess I’d left underneath the gradient inside. But I still got nothing from the right-click:soften edges menu, making sure I only had the edges selected. I did notice that when you look at the entity info, there are separate soften and smoothen enable buttons when selecting edges, but these don’t seem to do anything either. Highly likely ‘operator error’ on my part still.

In the end, I simply used the alt-erase function on each of the triangles individually to smooth the surface which seems to have worked nicely.

The Sandbox Tools are not available in the web version. That is correct.

The Soften/Smooth option works for me in the web versioon. There’s one edge on the left that doesn’t get softened because there’s an internal face that needs to be removed first.

1 Like

Ah…! The bottom of the ‘DISPLAY’ menu - that does work! With the ‘angle’ slider as well. Hadn’t spotted that, thank you.

So basicially ignore the right click:soften/smooth menu…?
Use the display menu or alt-erase functions instead…

Maybe not totally ignore it. It’ll soften edges with the angle set by the slider. In your model the required softening angle is larger than the default 20° because of the coarseness of your surface.

As I wrote in my first reply, softening those edges in your model will make the surface look smoother on screen. It won’t remove or reduce the faceting in a 3D print. You would need to create smaller facets to do that.

Apologies Dave, for some reason I’ve only just seen this reply!

Those are VERY smooth edges on your 2.2 file and I am indeed printing this.

1 Like

Understood, thank you.

And regarding the right click menu, I had no idea it interacted with the ‘display’ menu - it doesn’t even pop up when you use the right click command.

In the web version Soften/Smooth in the Context menu doesn’t and isn’t supposed to open the Display panel but it will apply the softening/smoothing angle set by the slider.

Click in sequence on the scenes tabs of this SU file for ideas.

Edges reversal for better looking curved face.skp (229.0 KB)

Thanks for that clear explanation, much appreciated.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.