Help - All lines in model are softened/smoothed

I’ve been hired to clean up someone else’s large, complex model which, for some reason, has every single edge soften/smoothed, even though they are all at 90 degree angles.
All of the lines are in many small components and groups, so I can’t select every individual line at once. I can select the lines and unsoften them inside each group, but it is going to take a very long time to open up each object to select the lines. “Unhide All” doesn’t work.
It’s probably a really obvious solution, but does anyone know of a way to unsoften all of the lines in an entire model all at once?

Everything is on Layer 0, and nothing else seems strange about the model.


Try exporting to dwg, then import it back into a fresh file. It will probably ruin the component hierarchy, however.

Alternately, this might be just what you are looking for.

1 Like

Ummm, can’t you select all and use the Soften/Smooth dialog to unsoften everything.

Box, I tried that first. The dialog box for soften/smooth doesn’t even activate. I wonder if the window doesn’t function on objects, or at least multiple levels of objects.

what are the edge settings in the Style menu?

if you copy/paste one item into a new drawing, do the edges show up?


Sounds like the edges are on the wrong layer and have been turned off.
Check the layering.
One option is to delete all layers, this moves all raw geometry back to Layer 0.
From there it should work.
If that isn’t it, I look again tomorrow. Sleep now.

what I’ve done so far is open an object, select all, and then use the Entity Info box checkboxes to unsoft and unsmooth it. The Entity Info also is what told me that the lines are softened, not just hid.

I’m going to try Alan’s solutions next.

Everything is on Layer 0. The edge settings are normal.

@john_drivenupthewall Edge settings are normal, just edges, nothing else. I tried copy/pasting one item into another model, nothing changed. Thank you, though! The process of elimination may help the next person with this situation save some time.

(added later…)
@AlanF, I just tried exporting as dwg and importing into a fresh file, and it worked! Thanks so much! And it didn’t seem to change the component heirarchy, either.

I really wish I had asked in this forum before trying it the hard way for an hour. You guys are all awesome, thanks so much.

If I have time I’ll try those extensions, too. Thanks for the link, Alan.

If you are up to it, you could copy/paste the following into the SketchUp Ruby Console:

Sketchup.active_model.entities.grep(Sketchup::Edge).each {|edge|
  edge.hidden = false
  edge.soft = false
  edge.smooth = false

Sketchup.active_model.definitions.each {|defn|
  defn.entities.grep(Sketchup::Edge).each {|edge|
    edge.hidden = false
    edge.smooth = false
    edge.soft = false

Another way is to turn on “wireframe” style, show hidden geometry, select everything and un-tic the buttons on the entity info window.
Return to “shaded with textures” and it should all look normal.

1 Like

@gadget2020 Thanks. I did that, as part of the process where I opened up a group and unchecked the soft/smooth options in Entity Info (as shown above in the image), and it does work, but unfortunately it means opening up all of the groups one by one. The trouble was that having edges be inside of isolated groups means that I can’t select just all the lines in the entire model at once, even in wireframe view. And the checkmarks in Entity Info are only there with raw geometry, they disappear as soon as I select an object.

This is perfect! I also just use Selection Toys to select only the lines.