Softened lines being unsoftened again by sketchup


#1

When exploding a component featuring softened lines I am finding many of these lines have been unsoftened again. Very annoying.


#2

That’s a known bug where selected entities can some times suffer from having the soft+smooth properties messed up. In my previous job I ran into this so often that I constantly deselected as quickly as possible.

If you see it happening then you can perform an undo to recover the original smoothing.

Don’t have any other workaround until we’ve fixed this I’m afraid.


#3

The trouble is it only happens when hitting explode. From what you’re saying I guess I’d either have to leave the thing as a component for ‘eternity’, or save my smoothing until I’m sure I no longer need to work on the model?

Edifying that you should acknowledge this as a bug. In the past I’ve been criticised for suggesting such things!

So that’s it then, just got to put up with it?


#4

I observe it for actions that might take a while - making the SU window unresponsive for a while. Explode often have that effect. Also minimizing the window with entities selected and restoring it.

Yes - it’s a bug. A nasty one IMO.

Until we can make and release a fix. I’ve been personally pushing internally to have this fixed, so I’m hoping we’ll see it addressed.


#5

Thanks. BTW: does the same bug apply to the ‘hide’ command? For my purposes this would work just as ‘well’ as soften.


#6

No. The bug is that when the window is minimized and then restored that actually trigger the Soft/Smooth dialog. (Weird bug) It’s also triggered when SketchUp becomes unresponsive - any operation that might take a while - and then becomes responsive again. You’ll see this bug more often with larger models as operations take longer.

So making your edges hidden instead of soft+smooth will not avoid this. It’s simply that soft+smooth is wrongly called.


#7

As another work-around:
Instead of exploding it, you could go into the component, select all, and copy. Then come out of the component, delete it and “paste in place”


#8

I’m not sure I’m facing same problem but it looks very close.

Situation
I’m exporting a single cylinder from our 2D kitchen Planner application in skp format with new C-API SDK (2013).
I’ve tried to set cylinder edges to smooth = true on all edges except on top and bottom of cylinder. Unless I explode twice the component holding the cylinder I Can’t see its curved survace as a smooth surface.

Question
Is it a bug In slapi or SU or a bug in my code ?

export 2015 smooth false.skp (15.9 KB) export 2015 normal.skp (15.9 KB)


#9

There’s a bug in the new C API where SUFaceCreate and SUFaceCreateSimple doesn’t merge the entities as they should. As a result your cylinder have edges and vertices overlapping - duplicates. This isn’t really valid in SketchUp.

This was discovered recently and until that is addressed you must use SUGeompetryInput instead.


#10

That saved my day. Thanks

I will not use SUFaceCreate neither SUFaceCreateSimple.


#11

Sorry for the inconvenience. This is a bad bug and it’s high up on our priorities.


#12

sorry, I had to revive this out since this smoothing bug is really bugging me at the moment.