Soften edges is inactive


#1

Hi! I’m beginner in SketchUp, and I have not found an answer to my question on internet…
I have a skp model converted with sketchup plugin from obj model.
When I trying to make “Soften edges”, the window is inactive… (object is selected).
What could be wrong with my model?


#2

As a guess, your geometry is probably grouped and you are trying to soften it without opening the group for editing.
But without a screenshot or the model to look at it could be any number of things.


#3

Thank you for your reply!

Here is .skp file:


#4

Looks as though (a s Box suggested) you haven’t opened the group or component for editing - the boundary box is still showing highlighted: selected, but not opened.

Try double clicking it first, or R-click/Edit.

On phone, so can’t edit the skp file to see for myself.


#5

It contains an amazing amount of geometry ! > 284000 entities !
It is also nested containers - multiple times.
You need to use the Outliner to drill down to the base levels.
Also its faceted geometry has many tiny edges [some < 1/1000" long], which might cause other issues…


#6

The model indeed has several unnecessary levels of component nesting. But more fundamentally, it is a very dense triangulated surface mesh that is going to cause SketchUp issues in any case. You also have a style with profiles turned on. That makes all those edges show up at the profile width, making the view turn black because there are so many edges. With profiles off, it looks like this because most of the edges are already softened/smoothed:


#7

Thanks for answer, but unfortunately your advice does not help. “Soften edges” window still inactive…


#8

I see the same thing even with a very limited selection of edges.


Soften Edges is not active and Soften/Smooth does not appear in the Context menu.

Edit to add: I copied a chunk of the geometry into a new SketchUp file and it showed up with the edges already softened.


#9

@DaveR did you turn off Profiles??

all the edges are already both…

john


#10

I’ve drilled down to the basis and see nothing…
To be honest, I do not know what to look for…


#11

The fact you see a blue box around your object means you haven’t drilled down all the way, you are still outside the last group, double click on it until the blue box goes grey.


#12

I didn’t turn off Profiles but I set them to 1. With Profiles turned off, the model does indeed appear to be softened/smoothed.

Interestingly, if I double click on a single triangle, it shows me that 4 entities are selected as I would expect but the edges don’t highlight.

With Profiles turned off, the softened edges show selected along with the face.