Soap Skin Bubble in SU 2016 64 bit = nothing

I know I could use Curviloft instead of Soap but I would like to find out why I’m unable to get Soap to work.

I have removed the extension and installed it to get rid of the the time lapse issue.

As stated in topic title, I’m using SU 2014 64 bit. Just a simple two arcs joined at each end with lines as a test.
After selecting the entities and clicking on the “Generate Soap Skin” button nothing happens. Absolutely nothing. No grid, no lines at all. I closed SU and opened it with a new model and same thing, nothing.

I also have SU 2015 32 bit and tried Soap in that. It worked perfectly fine. No problems at all.

I’m at a loss.

Hmmmm… It works for me on SU2016 64-Bit.

What happens if you try running it while the Ruby Console is open?

Where did you get the copy of Soap Skin Bubble you installed?

Straight out of the extension warehouse through SU just last night.

His user-name seems to be ‘ron’ so that looks OK !

Do you have the following files and subfolder in your user …/Plugins folder ?

  • SoapSkinBubbleTools.rb
  • /SoapSkinBubble/SoapSkinBubbleMenus.rb/rbs/rbe
  • /SoapSkinBubble/generateSoapSkinBubble.rbs/rbe

The first names the second when setting up the Extension.
The second loads the third, which defines various methods etc.
It then makes tools using those.

Your error message shows that it’s failing to load the RBS file, and therefore the tool ‘GenerateSoapSkin’ is not created - hence the error.

Check for the files etc.
Did you install for its RBZ, in the now traditional way ?

When you installed SketchUp from its exe installer did you right-click its icon > context-menu > run as administrator ?
If not, even though you might have admin powers, it can cause hidden flakinesses…
If you didn’t do it that way can I suggest that you consider uninstalling SketchUp via the Control Panel ‘Programs and Features’ and the reinstall as admin…
Any plugins and licenses etc should be safe…

The error message seems to say that the plugin’s installation is defective; it is missing a module. Did you install directly into SketchUp via its EW interface, or download the files via a web browser and install them yourself?

Straight out of the extension warehouse through SU just last night.

Files I have



Ok. All is good now.

I uninstalled and installed as Admin.

I marked TIG’s reply as the solution.

Thanks TIG!