How do I get a version of Soap Skin and Bubble that will work with SketchUp 2017 Make

I recently tried to use Soap Skin and Bubble. The newer version that I tried to download said it was not compatible with with your Operating System or SketchUp Version. And the older version I had used before says Timelimit finished.

Did you actually try the current version of SSB anyway? It will likely work.

It didn’t do anything when I tried to generate a grid

Can you share the .skp file?

If it really doesn’t work with SU2017 Make you’ll need to contact the author to see if he will release and older version with the time limit extended.

I tried the new version again and it will generate a grid but that won’t do anything.
image
Here is the .skp
Untitled.skp (82.5 KB)

I selected the frame and then clicked on the Generate Soap Skin Icon. Am I missing doing something?

Did you then press enter?

Yes, it just isn’t doing anything

Does anything happen in the text shown in the upper left corner of the screen? How long are you waiting for it to do something?

Open the Ruby Console an try to run it. Copy whatever shows up in the console and send that to the author of the extension to see if he can help you out.

This is what I get when I run it on your model although I am using SU2021.


After selecting the edges and clicking the first button on the toolbar, you can change the number of divisions to get a smoother bubble. I wouldn’t do that until you first get it running with the default number. Or maybe try fewer divisions to see if it’s just a processing thing with your computer.

image
It has been that way for 10 minutes. I opened another SketchUP file though and it worked in that one. Maybe I just have a glitch in this file. It isn’t frozen but it just will not do anything with Soap Skin & Bubble

Maybe you just needed to start SketchUp after installing the extension to get it fully loaded.

I don’t think you have a glitch in the file. It clearly worked for me here.

I don’t know what it is because when I tried making another frame in the same model it worked just fine. It just will not work on that frame.

But that is Ok, as long as I can make the frame again

Close that file and open it again and try. I’d expect it will work.

Yes it did. Thanks

Do you think it had anything to do with me trying to Update the extension after clicking the Generate icon

Maybe that prevented it from fully loading.

That sounds a little like trying to replace the engine in your J3 while you are in flight.

Thanks, I will not do that again. I will get out of what I am in and open a new model before updating. If it ever freezes on the grid again.

You don’t necessarily have to do that. Just don’t try updating an extension while it is trying to run. Some extensions also just require a restart of SketchUp to fully load. Better to update an extension, close SketchUp, and restart.

1 Like