Snapping to some point far away + unable to undo

bug

#1

Hi,
Since I’ve started using sketchup 2018 there’s been time when I try to move edges of a component and it suddenly snaps to some point really far away, creating a completely messed up component. The weird thing is that I can’t undo the action. When I press CTRL + Z it “undoes” all actions except for the one where the snap happened.
There’s no other option than to redraw the component, which is not really time-effective…
Any ideas what might be causing this?

Also, I’ve noticed that the number of undo-actions has been downsized, could it be? Is it possible to make it bigger again?

Many thanks!

Sigrid


#2

First question: how are you performing the move operation? Here is what I do:

  1. Select the entity to be moved (unless you are moving an endpoint by itself).
  2. Click (and release) the mouse on the entity or endpoint.
  3. Move the mouse; the entity or endpoint should track the cursor as you move the mouse. If you see SketchUp jumping to an unwanted inference point, either press ESCape to cancel the move and start over, or just keep moving the mouse until SketchUp “gives up” on that unwanted inference point.
  4. Click the mouse a second time to finalize the move.

It seems very odd that the unwanted movement action cannot be undone. That suggest to me something else is happening, not a typical move operation. Can you post a screen shot of the result of an unwanted move? (Use the upload button, seventh from the left in the forum reply toolbar.)

Regarding the depth of the undo stack in SketchUp Pro 2018, I have not used it enough to notice if the stack has shrunk.


#3

Hi, thanks for the reply!

I just had the problem again and made a screenshot. I was using the push-pull tool to extend the wooden workface and all of the sudden it snaps so some point that wasn’t even in my field of view at the moment.
I can’t undo this and have to redraw the wooden element.

(for the record, I was extending it towards the bottom, not to the left so it would be an L-shape.
(can’t post second image since I’m new here)

I’ve had the same issue when selecting edges and moving them with the move-tool.

Crazy, isn’t it?


#4

Could you share the file itself, from before it happened?


#5

I didn’t save it then… I’ve finished the model for rendering tonight.
If it happens again I’ll try to remember.
I’ve had this happen in nearly every model since I’ve started to use sketchup 2018.


#6

Most of us have never seen this happen, so it must be something particular to your computer or the way you use SketchUp. For the latter, as @Wo3Dan noted it is extremely difficult to diagnose without an example model. I’d also recommend that you get into the habit of saving your model frequently anyway, as that will avoid losing your work altogether if SketchUp or your computer crashes, and in this case would help you to get back to the situation before the move went astray.

Regarding the former, please put correct information in your forum user profile as it will help us recognize whether your particular computer setup is known to have problems. You left most of it blank and put “Interior Design” where it requested your graphics card!


#7

Hello!
I just had the same problem again and I saved the model. The file is too big to upload… This is a wetransfer link: https://we.tl/NKp6bHkOWC

I’ve edited my profile as well. I’ve been using my system for a few years now, never had any problems…

As for plugings, I use Vray for sketchup 3.6. I Must say, there was an upgrade for Vray at the same time sketchup 2018 was installed… Don’t know if they’re related…

You can see the cabinet I was drawing just snapped to some place outside the room, the undo-option is not available… The only option is delete tha cabinet and redraw…

I have autosave enabled every 5 minutes, but still, it’s annoying :slight_smile:

Many thanks!

Sincere greetings, Sigrid


#8

Hi

just wanted to ask if you have found any solutions or ideas what is causing this, as exactly the same thing is happening with my model as well? especially when editing components but could not figure out if it is file related or not as I do not use Sketchup on all my projects.

I have Vray for SKUP as well…

thanks


#9

Yep I’ve had this since 2018 pro version. Either moving a group component or geometry (which then goes completely haywire and corrupt) can’t undo.
It’s deffo related to auto save, if you disable it the problem disappears.
Other people are suffering too- search the forum, there is definitely a bug out there. I’m on a Mac, it may be limited to that platform.

It’s not every time but it happens at least once each day. Problem is I’d prefer to have AutoSave on as I get a fair few bugs plays each day, so better the devil you know.


#10

I also use vray 3.6.02 - usually the bugsplat indicates vray (if it is vray) but I get the wierd moving bug even if I haven’t enabled the asset editor.


#11

Hi… No solutions yet…
I’ve had it happen SOOO many times now. I’ve also noticed it happens when sketchup is “autosaving” during a “move”-action…
But working without autosave is not an option…
So I hope Sketchup will fix the bug soon!!!
This just happened now, while editing the roof component:
bug|690x387


#12

Turning off auto save was one of the first things I did over 10 years ago when starting learning SU. Back then I used a very low end computer and modeled very large models. A project could easily take 10 minutes to save. Even now when I mostly use SU professionally on a lot simpler models I can’t stand having SU freeze a few seconds every few minutes.

Not saying this is a solution to the problem, I’m just pointing out SU can be used without autosave. However, if doing so you MUST learn to automatically hit Ctrl+S whenever taking some notes, looking out the window to think, going to the bathroom, poking your nose, stretching and on every other occasion SketchUp has a few seconds to spare. If you make that a habit you can have even more frequent backup than the default 5 minutes of the autosave.