Geometry Glitch on Move - model destroying

Sometimes when I move some moderately complex geometry the whole thing moves WAY off to the side and at a rotation that seems to be random. It’s impossible to move back, so large parts must be deleted and redrawn. Stability suffers too. This is often followed by a crash. Glitch often looks like this:

Any tips as to what might be causing this would be helpful. This is a 30 minute setback or more that happens way too often to ignore (albeit not every day).

I’m not sure about the why, but I’m curious, you can’t Undo? (Edit>undo)

Shep

Good point, I forgot to mention. Undo is not an option for some awful reason. I get the fix file dialogue every time, but it doesn’t help whether I “fix” or not.

It’s like a gremlin is trying to ruin my day. I know Skalp plugin inhibits undo sometimes, so maybe there’s a weird interaction there. Also, my autosave file seems to update immediately when this happens too. I may be able to catch it if I force quite as soon as it glitches next time, but I was too slow today. Even though I went right for the autosave file.

The next most annoying effect is the many hidden lines that are created when the geometry goes wonkey. They need to be deleted before pure geometry can be remade. :weary:

I don’t know your workflow but could you disable Skalp (if it is inhibiting undo) until later in your design process?
I would hate to be without undo, I even have undo and redo programmed to mouse buttons.

Shep

Shep,

Thanks. I think that makes sense. Skalp doesn’t entirely disable undo. Only from time to time, but leaving it off/disabled for most of the work does make sense.

-Alex

Any chance you can post the skp file

Well, it’s 35MB, but more importantly I fixed the geometry already, and it’s a project in commercial development. I am hesitant to put all my junk out there like that. If it happens again, I will save and keep the file in its wonky corrupt state. Maybe I can recreate the error on a simpler file that we could pick apart. Thanks for offering to look at it.

What is your workflow? Did you group these geometries separately or not? If not, then the result is to be expected.

Everything is grouped. The result is more than a twitch of the wrist or accidental click because when it happens the affected plane is rotated and translated in such a way that no tool could do in one command.

One thing I know I can do is have smaller groups of walls instead of one group containing all exterior walls. That way even if this did happen, it would have fewer intersections/geometry to clean and rebuild.

Workflow here was to click down to the wall group. I tried to use the Push/Pull tool, but I had a hidden line or something. That didn’t work. I switched to move tool and dragged the face (the top of all the walls in the group) up to snap onto some geometry that was not in the group. Then the glitch happens. I wish I could remember more clearly the other conditions. The walls were made with Profile Builder2, but had been modified quite a bit. Skalp was on. perspective view. Not sure what else could be relevant.

I have seen this glitch about 3 or 4 times in hundreds of hours of SU use, so it’s rare just particularly annoying. Again, thanks for your attention.

For what it’s worth I have seen something kind of similar, involving the geometric verification operation that occurs (by default) when saving a file, coupled with the Undo operation. My models tend to have very small geometry (even when working on components at 100X normal scale), and all too often when I save the model, SketchUp will do its well-known action of deleting very short edges, etc. thus producing holes in what had been a solid component. These days I just hand-fix the geometry when this occurs. In the past I would sometimes attempt to use a multi-level Undo to revert to an earlier stage of model development with the hope that a slight alteration in the intervening geometry would avoid the verification “damage” or yield “damage” that would be easier to hand-repair.

The point of my story: I often found that the first Undo (of the verification operation) would yield a radical modification to the model’s geometry. Dozens of edges would be created via the Undo operation, spanning the space between some actual geometry and what seemed to be the world coordinate system origin, or similar. As a result dozens of large triangle faces would have been created by Undo “in the middle of nowhere.” Attempting a second-level Undo would make some tweak but usually hard to determine exactly what. Sometimes doing a few more Undo operations would suddenly remove all the huge spurious triangles created by the first Undo (of the verification operation), and the model would be cleanly back to an earlier stage.

I probably encountered this most recently in SketchUp Pro 2015. As I mentioned, I have gotten out of the habit of trying to Undo a verification operation, so I don’t know if SU 2016 or 2017 would still sometimes yield crazy geometry after undoing a verification (which had itself made changes to geometry).

Alex when I initially saw this thought you have some extraneous geo hiding some place that is causing the issue but>>

  1. Turn off any auto ops you have set in you model;
  2. Set to wire frame mode, hide and right left select as close to model you can get, select all and then delete. Un-hide and try your move. Hidden wire frame use to be non selectable but who knows with all changes, of course do on a model copy;
  3. Copy model over to clean SU window and try move.
    Good Luck

Having the same problem for a while!

It gets quite annoying if autosave is programmed in short periods of time, like every 5 minutes.

If autosave happens in the middle of face editing, Sketchup sends the faces that were being moved to (an apparently) random place in space.

Undo does not make effect, as the operation available to undo is “Properties” (?). If you are lucky, the group/component is simple enough, and the resulting geometry doesn’t cross its own faces so you can fix it by realigning the stray faces. Although, my most common case is having to go back to a previous version of the file.

Trimble! This is obviously a bug of yours.

(Mentioned before on this thread, I do not have Skalp installed).

1 Like

I had various unpredictable issues with a large sketchup model. It turned out to be a flaky mouse. I purchased a
Cadmouse and haven’t had any issues since.

Update: Autosaving (to a cloud service at least) has been the root of my crashing on 5 minute intervals. I am not using autosave for now and my stability is much better. Maybe one crash per day rather than 5 to 10. I’m not sure if this is fixable, but I am a manual saver by habit now.

Exact same problem and I’m getting it frequently.

I go to move or push/pull a selected face along a standard axis and then as I click to confirm it decides to send the geometry along a completely random axis a random distance. It is 100% a glitch as you are unable to undo this option. It appears that Sketchup does not recognise that the geometry has moved, your undo options are as if the move didn’t happen and it will undo the work in this new position. This means you are unable to simply move it back. Its very difficult to manually move the selection back as it is in such a random position and has distorted all the faces connected to it.

Really frustrating that this keeps happening. Clearly sketchup doesn’t realise it has moved the geometry to this random location as it can’t be undone, as far as sketchup is concerned there is no move to undo.

Error

I wonder if its due to this. This keeps happening and I’m unsure why.

In this instance i’m drawing a rectangle between the two other rectangles. I’m pulling it along the selected axis in the left hand image. Then when I reach the next rectangle it suddenly jumps off the screen rather than clipping to that line as requested. The point it snaps to has nothing to do with the other geometry. I wonder if this is linked the problem above - sketchup snapping to a random point when moving geometry?

It still doesn’t explain why sketchup doesn’t know its made the move / the object can’t be undone.

Yes I get this a lot too - it’s related to auto save I think, when moving something it hiccups and then we’re into Wipeout style geometry (or that’s what it looks like to me anyway) - and can’t undo.
I also have also noticed the move thing as well if you are not in a geometry level group or component it will just ping it miles away, it’s looks like it’s disappeared but if you zoom extents there it is. The double whammy is that it’s doing the auto save so the backup is affected too.

1 Like

Definitely an autosave issue. If you in the middle of a move command with geometry selected while an autosave happens there is a chance that this happens, and the autosave file is affected. Undo also breaks.

I have turned autosave off and not seen this issue come back until I installed SU on a new computer and I forgot to change the autosave settings. I got the funky geometry glitch again, but only lost 20 minutes of work. The worst part of all this is autosave is not a feature anymore.

Are you constraining dimensions? I’ve seen this happen with dynamic components where a sub-component freaks out due to a mix of formula dimensions/positions, and numeric inputs, or leaving it blank. For example a cabinet side I leave at position 0,0 because that’s where it should start. I set a Zero variable, and =Zero instead of leaving it default, and they stop misbehaving.

I have only had this problem when editing raw geometry. Component constraints have their own set of problems, but I think your suggestion will be helpful.