SketchUp messes with my geometry!

Does anyone experienced this: Since 2020.2, about 2 - 3 times a week, SketchUp mess with my geometry while I’m editing. During a simple movement, SketchUp moves the selected geometry away from its position. The worst thing about this is that it’s NOT UNDOABLE. So I end up with a corrupt drawing and I need to recover the last autosave to keep going. I then adjust my auto-save to 3 mins.

It’s a real pain this problem!

I did a Fix Problems, and here’s the result:
Results of Validity Check.
The plane equation for CFace (276854) is not valid - fixed
The plane equation for CFace (277156) is not valid - fixed
The plane equation for CFace (277215) is not valid - fixed
The plane equation for CFace (277256) is not valid - fixed

But it doesn’t change anything as it’s still undoable.

Share the .skp file with us.

I can’t share the all thing. But I did a save as on the component. But it doesn’t appear only on this model. It happen 2 3 times a week with all sort of model.

Component_66.skp (39.5 KB)

I think you’ve removed the part that causes the problem. Go back to the original file, select the component and copy it. Then go to a new file and use Paste in place. Save that and upload it.

here’s the original. From the previous revision.

Component_65_(Original).skp (38.3 KB)

That didn’t help.

I need to leave this to someone else.

I think I have seen it mentioned here before. I am not sure, but it might have been a plugin that goes awry when Autosave kicks in. The “not undoable” bit points also to that direction.

That’s what I think also. I have a strong feeling the mess happen while I was doing the movement and the autosave kick in. I increased the rate of auto-saving at 3 mins, and by doing that increased my chance of this happening.

I don’t think the answer is in the file Dave. But thx anyway.

I looked at the second uploaded file. There are no components in the upload. It is all loose geometery.

Added the word second

The first one has a component.

Here’s the original file, as a component:

Component_65_(Original)(Comp).skp (119.9 KB)

Related thread?

Very interesting. I do have VRay… It’s installed but it’s disabled in Extension Manager.

I’m not sure Vray has been definitively blamed but it sounded like the same symptoms.

But it’s kinda confirm the source of the problem: The auto-save.

I remember in the old days. Autosave was making my autocad crashing and I never seems to find a fix to it.

oh, dear!!! it happens again.

I had an experience with another extension causing issues even as it was disabled in the manager. complete removal was the only solution.

1 Like

Cool avant-garde architecture! Your design is improved! :rofl:

4 Likes

This comes up quite regularly, there are many threads about it but they are hard to find due to the unusual nature of the issue and therefore the strange thread titles of people trying to explain it.

Basically it has been tracked to autosave reacting to a selection of extensions. No one extension has been pinned down as the culprit, seems like it can be a mix, the only common denominator is autosave.
Turn it off and get in the habit of manually saving regularly. Having autosave kick in right in the middle of something is a pain anyway as it slows things down. Much better to save regularly, once you reach a specific point, before you use a complex extension, whenever your fingers are near ctrl s.

3 Likes