SketchUp messes with my geometry!

Yep, just happened to me twice in about a half an hour just the other day. I’ve been seeing this for years.

I also used to have this awful problem and I think (from the very vague memory I have) it may have been related to my 3dConnexion SpaceNavigator.
Are u using one of those ?

I have not been using one … yet. I just bought one, but not installed yet.

To the best of my knowledge the 3d connexion has not been associated with this issue.
There was a 3d connexion driver at one time that caused sketchup to crash if you tried to orbit with the move tool over a vertex.
And there was a run away memory error with mac that was problematic.

1 Like

Yeah… memory issues in the past, but 3D mouse drivers should not be touching geometry… as far as I know this was due to renderers.

i turned off the autosave for few days. Didn’t the problem since then.