Geometry moves inadvertently

Sometimes when moving a plane or a line in SketchUp, I move it over a certain amount and shoots over 40’ in a completely random direction. Ctl+Z doesn’t undo it, it is if it didn’t happen. Below is an image. Any thoughts on why or how this is happening?

Is the model at a great distance from the origin?

Are you really modeling with the Sketchy line style you show in your screenshots?

I don’t think it is far from the origin, I do have the google terrain imported. I am not normally modeling in this style, typically I have something more normal and edges colored by axis. I have been using this style, but not in X-Ray for SD models lately. I only noticed this in the past 6 months or so and is happening more now. I do have FlexTools and noticed a lot with that too, but I’m not using it in this model.

The origin is the center of the model, so not far away at all.

Maybe try turning off the layer for the terrain so that isn’t visible. (Note: it hasn’t come from Google for some years)

I would suggest you model in a non-sketchy style.

I’ll see if it happens in my normal modeling style, I believe it does, but we shall see.

Where does the terrain come from now, I assumed it was still from google earth?

This looks like a bug that has been around for quite some time and is triggered by a plugin interacting with autosave. I don’t remember if anyone has pinned it down to something specific.

It comes from Digital Globe and has done since Google changed their terms of use which made it not possible to use their data and imagery.

Got it. No wonder it isn’t as crisp and detailed as google maps :unamused:

Just for fun, this is what the model looks like. Some Rough SD brainstorm modeling for us and the client.


Well, Google took their toys and went home. That left the SketchUp team searching for another global solution for the location feature. The options available aren’t free. Digital Globe offers higher res imagery but at a price that, if offered to all in Sketchup would drive up the price. Many users don’t need that kind of detail if they even need the Location feature. (I don’t need it except when I’m tutoring my students. In my regular work with SketchUp the location feature is not useful at all.) If you need higher resolution terrain imagery it is available through Placemaker II or is it III? Anyway, for those who do need it, it’s available.

The model looks nice but I would reserve that sketchy style for display only. Modeling with it would be somewhat difficult.

Which style is it?


Thanks for the info on site imagery.

For the sketchy style, it’s a modified version of Fineliner. I do use it for display only, but on really simple models a quick adjustment seems to work just fine, but the end points aren’t easy to recognize, hence why I don’t typically model in it.

1 Like

It happened again without being in that style.

What were you doing when you were editing the group/component?

I was moving the plane that is sticking way out in space over 24" on the green axis. Ctl Z doesn’t move it back it undoes the last thing that was done assuming that the plane was always in this position. It seems to be random when it happens and has happened on 2 different models (completely different projects, i.e. no geometry copied from the one to the other.

The only way I have found to undo it is to delete the geometry that has moved and redraw it, usually takes a minute or two but still annoying.

I went back to what I had and tried to repeat the same process that resulted in crazy geometry movement and it did what was expected this time…

Can you share the model?

I can, but the error has already been undone and is still a work in progress. This is my first time uploading a model so let me know if this didn’t work. It is 36 MB

NVM that link, that goes to the folder, try this.

You need to provide permission so it can be accessed. Try uploading it to Drop Box and share the link.