Geometry problem

Hi Guys, I have a serious problem with many shapes in a huge structural model. Some part are simply a huge pain in the ass to edit. I could isolate (save as) an indiviual problematic peice and did a small vid of the problem. Can anyone explain me why sketchup is acting that way. The same bug create a lot of problem when I drill a hole though the piece. The hole doesn’t go through!

One thing I was thinking is that I use a different axis setup for every component. This piece is a structural knee brace, and you want the axis to be align like the raw piece of wood. But I have the feeling that it’s what cause the problem.

By the way, hidden geo is turned on in the vid.

here’s dropbox link for the skp and the video.

That is not a bug, it is bad geometry. The piece you have drawn is twisted.
I usually start drawing it again in the right axis .
It happens to me too, when I change axes a lot and when I borrow groups from other models or I don’t check the accuracy of the drawings .
A fast fix would be to keep a side and pull it again. If you can explode and regroup it will be even better.

First, it would be a good idea to give a brief written description of your problem even though you provided a video. What may be obvious to you in the video might not be to anyone else. Why risk miscommunication?

I take it that the “bug” is that you can’t Push/Pull the angled faces cleanly without leaving a mystery face behind. I quickly modeled a copy of your geometry and had no such problem.

Like @ely862me, I must conclude that your modeling technique is at fault.

If I, a beginner, couldn’t get something to work right, it would take many, many failed trials to convince me I had discovered a bug rather than had simply screwed it up. Indeed, I have been astonished over the years at how often some rank tyro will screw up a construction and immediately conclude he’s discovered a bug in the program. I believe this is called hubris.


Thanks ely. Good to ear that it happen to others as well. I know my shape is twist but my struggle is how it happens! I draw perfectly straight many parts, taking care of good alignment but somewhere in the process, the parts become twist… and I didn’t twist it. It suddenly happen. So my theory is that I drawn the piece perfectly in the main axis, then position the part, then change the axis then edit it. So the twist happen during one of these process. The change axis is the most logical to me. It might be when I change the axis, there is a tiny difference who make the faces not being perfectly aligned. Someone suggest on the forum to create two guide line to change your axis, instead of grabing the corner of the part. I will give it a try…

To be clear, I never though this was a sketchup bug! Otherwise, I would directly contact them… When I was saying BUG, I was meaning MY bug. English is not my mother tongue, sorry for my lack of vocabulary.

Before sketchup, I was modeling in CAD for years. This is something who would never happen with autoCAD because the software would never let you do such a move. (this way at least) It was a real pain to edit in CAD because its tolerance was zero… It’s interesting to see that sketchup let you twist parts (practical sometimes) but hardly showing you. Even with the visual option Color By Axis, it doesn’t show you the twist.

Gully: thanks for your reply. Sorry for the short description. It was something very hard to describe and only a video would explain it. I’m a manual kinda person, not an intello, so if someone would have post a subject like that to describe the problem, I would not get it.

If you read my post, I’ve only use the term Bug once (my mistake) the subject here is not about who’s fault is that!!! Is about what cause the PROBLEM and try to fix it. I don’t have time to loose throwing rock to programmer, I just have enough time to write a post trying to find a fix to my problem. Thanks for your help.

NEW: I redraw the shape from scratch in component edit who have a different axis, then extrude it. Close it. Back to my main drawing, go back to edit the component with a different axis, then the part is twist again!!! It’s friday night, and I’m giving up! I’ll try again next week. :grimacing:

I usually do the fix like this, double click on the face, Ctrl+C then Ctrl+A, Delete, then Ctrl+B(paste in place) then do the Pull and it usually works, as the shape will now follow the axis. If this doesn’t work, then draw it from scratch outside any group.

I see what you mean, I’ll add this option to my toolbox. I think the “outside any group” is interesting. Thanks a lot.

Well, yeah, aside from naming both your video and your .skp file “bug.”

Speaking of your .skp file, I just tried the same Push/Pull operation on the model you provided, and once again I had no problem with Push/Pulling an angled step into the material, so it seems as though the slight taper (which I confirmed is present) is not even the problem.

As for grouping, I generally hold off grouping an object until I need to, either because construction on the item is complete or because I need to put it into contact with other geometry.


So here it is… Even if the face is twisted, you still can push pull!!! That’s weird, don’t you find?

There is level of allowance where sketchup can close a face regardless its non coplanar edges.
I believe the culprit in you part is mostly this endpoint, if you move it freely it won’t touch the endpoints of those segments. When you move it with Alt to force it on an endpoint, the part seems to start behaving.

I didn’t say twisted, I said tapered, which I believe is more accurate. No, it’s not that strange: the off axis face was not involved in the Push/Pull.

You keep trying to imply that some supernatural power or some other mysterious agency is causing your problem, when I really think you just need to keep practicing until these anomalies eventually diminish and disappear as you gain skill. I really think that it’s just a problem with not using inferencing consistently to locate each and every point.


Me again… I keep modeling today, and for some weird reason, all the part i’m working on give me geo troubles. They all have something in common: they all at an angle, and the component have the part angle as axis. I keep thinking that working with different axis (different angles) create my problem. Here’s a skp, can you please take a look at it and try finding the reason those 6 holes (3 per sides) doesn’t go through. Whetever I draw them from inside of from outside, I get the same problem. I’ve created the mortice with guidelines. 3.75" from the side, 3.5" deep. This time, this part is not twisted. Problem 3.skp (183.2 KB)

FYI, I did a quick fix by moving the end of the holes out, then I apply a Intersect-Context, then I can see through but everytime I use intersect in this situation, I create weird multiple face. It’s like fixing a problem by creating another one.

Those faces are not parallel unfortunately. Again, this part is wrongfully drawn. Color by axis is not that accurate, this has been discussed somewhere.
Also, you can see when I draw the first line that the first endpoint is not on the same axis with the second endpoint otherwise when I tried to draw to the second endpoint it should have shown endpoint not on edge or constrained.

If you draw the recess again it will work, it worked for me.

ely, Big thanks for your reply. I finally have my conclusion. I did the same thing you did, and I did it 5x. It works 3x and failed 2x… You know when you kept the little line, this line was draw from a guide line that I copy paste from the Tenon part. I understand that this guide line was not exactly on the same plane than this part. The first time I created the line, it failed, then I did it again, and it works… So I start over, failed, works then works! So that mean, because the high tolerance of sketchup to create faces, it’s not a stable situation. Sometimes, it let you create a face even its stuff around are not straight, just like you said before. Its pratical when you want a rush result but not when you want to draw the perfect geo.

My guide line was drawn into the other part (with a different axis) and I then copy paste them into this part so I would have my reference. Thing is, I can’t truss those reference because the different axis between the two parts. In this case, I should use only perpendicular guideline (on the intersection point), and never use parallel lines. Because they are NOT parallel. That will be a habit to change.

Big thanks for you time ely. I was outrage today and I needed an external POV to make me see what I was doing wrong.

I toke a small look at your rendering. Some of them are really good looking. I’m surprised you don’t use Solidworks or 3Dmax for the mecanical purpose.

small last question. what do you use to do those small quick video? Camtasia?

I have tested your model with my plugin and found that the problem was only that there was a solid entities and ungrouped edges on the same group level.Fixable with one click.
EDIT: About the holes in the middle I found that the solution is (beside redrawing) to copy the model,open a new Sketchup file and paste the model there.In a new file it is possible now to intersect those circles with the model and then delete them to make holes.

The strange net you refer to is hidden geometry.

Thank you Box.Do you know when this net appear,because if I draw a box and then hide one face I can not see this net.

You’re welcome !
Usually when you rush things problems occur, in a way or another. If you use these components in each drawing, you’d better make them right because you will have to rework them every time you use them.
Why are you changing the axes though? You don’t need to change them, because there are easy components, straight lines, square angles.
I don’t use guides much(but I am not doing this kind of work). I usually draw lines, divide them or create arrays with the move or rotate tool.
I like working with Sketchup, it gives me ideas and is so easy to work with.
The program I used for the screen records is called Screen to gif or another one GifCam.

Turn on hidden geometry from the View menu.