Solids acting erratically

I have been using Sketchup Pro for a few months, and have used all aspects of solids. I have found Sketchup’s concept of solids to be lacking, as I started solid modeling in AutoCAD. But, I have become thoroughly familiar working with solids, or so I thought. Recently I have encountered a lot of strange behavior. Without going into a lot of detail, I’ll describe my latest encounter.
I created a simple 20’ X 30’ wall structure that is 96" high, and 6.75 inches thick. I then made a 60" X 30" opening in one of the sides. I then move/copied the opening, and multiplied by five. I have done this process many, many times, but this time all of the copies could not be push/pulled into an opening, and my solid wall is now a group. I’m not sure if I should re-install, or what. This is my first time here, and I’m not sure how to upload the model, which might be worth more than a thousand words. Any suggestions, or thought?

This makes me think you have some misunderstanding of some fundamentals in SketchUp. How about sharing your .skp file so we can see exactly what you’ve got set up and help you sort out the problem.

Drag and drop the .skp file into your reply.

This is what I get when I do what you describe in my own file.
windows

Thank you for your quick response. You have just confirmed that I have a bug in my installation. What you are doing is what I have always done. It no longer works, so I have a problem in the program itself. This has been my suspicion, since I have been experiencing a lot of very erratic behavior recently. I probably should contact Tech Support directly for suggestions.

Let’s see your SketchUp model before you call it a bug or try to get in touch with Tech Support. I expect there’s a simple explanation.

Solid Test.skp (344.5 KB)
Sorry, I forgot the file.

You didn’t do what I did. You created the opening and copied the entire opening. In that case you need to intersect the faces and then delete the skins over the openings. This isn’t a bug and there’s no need for you to put in a support ticket.

windows

The fact that the edges around the copied geometry are shown as thick profile edges instead of thin ones is a clue that the surface hasn’t been divided into regions inside and outside. Notice after the Intersect Faces operation those edges switch to thin normal edges.

Make sure you don’t leave the blue reversed faces in your roof exposed. There should be no exposed blue back faces in your model. Also note that ALL edges and faces should be untagged. Only objects (groups and components should get tags. Some of the geometry in your roof group is not untagged as evidences by the blank Tag field in Entity Info when the geometry is selected.

The fact that you created a group for the walls has nothing to do with this.

Amazing! I have never done that before, and it worked just as you demonstrated, What I’d like to know is, how did this work for me so perfectly all the times before - and there were many - and I have never used that process. I’ve worked on projects for people while they’re sitting right here watching, and I’ve never had a problem before. This can’t be my imagination, or I’ve got company. I intersect faces in many circumstances, but never here before. I certainly will from this point forward. Thank you very much for your help, and I’ll will try to figure out how this worked so well before. There isn’t much that can be done to complicate this model. If I’ve learned one thing, it is to keep everything to an absolute minimum when creating a 3D model. Doesn’t matter if it’s in Sketchup or AutoCAD … keep it simple.

This is not new behavior. It has been this way since the beginning. Or at least since V3. If your walls have no thickness an opening can be copied.
windows

Here’s in 3.1
windows2

1 Like

I have to wonder if that’s the answer, but I have almost always worked with walls that have thickness. But, since I can’t clearly recall a specific instance, I’m going to chalk it up to the learning process. What got me really suspicious is that I’ve had issues that developed while I was working on a model. In other words, something worked, and then didn’t. I have learned though, to look hard for something I’m doing that might be the cause. So, for now, I will pay very close attention, and document quickly when I think something might be wrong … besides me that is.

I did notice you have Length Snapping enable in Model Info>Units. That can be a source of issues with inaccuracies in your models. Maybe that’s had something to do with other problems you might have had. The general advice is to not use Length Snapping.

Hip Roof Axes.skp (389.8 KB)
I have disabled Length Snapping. I have no idea what it is, and it came pre-configured that way. I don’t know if it has any relation to OSNAP, as in AutoCAD or CorelDraw, but this is one of my biggest complaints about Sketchup. Snapping to what is there currently is a real pain, and enormous time waster. But what’s really lacking is the specificity in AutoCAD, such as the center of a circle, or the circle quadrants, to mention a few. Just seaching for the midpoint of a line or group can really test one’s patience I hope they will improve this in the future.
On another subject, I’ll include another model for you to look at. In this one, I wanted to align the axes to the hip angle. Do you know of a simple way to do this? I figured one out, but not sure why or how it works.

It sounds like you need to spend some time learning about using Inferencing in SketchUp. It’s very powerfull and quick when you’ve learned how to use it.

Hmmm…
midpoints

Like this?
axes

Something to keep in mind along with all Dave’s excellent info, going from Autocad to sketchup is like a fixed wing pilot trying to fly a helicopter. Yes they both fly and many of the principles are the same but treat one like the other and you are bound to crash.
If you come to sketchup with no preconceived ideas about how it should work you find it easy to learn, but many Acad users find it frustrating because they have to relearn the muscle memory and ways of doing things. Take the time to ‘learn’ rather than ‘guess from previous experience’ how things work and your productivity will come on in leaps and bound.

1 Like

Inferencing is something I use constantly, and I think it’s an extremely useful, if not indispensable feature. As to snapping to various points, what you’re demonstrating is on small and simple objects. But in a very large model, one has to zoom in quite tight to find the point, and it doesn’t jump out at you when you are near it. That’s what slows things down. When I get near an intersection, I want the program to make it visually clear. Sketchup simply does not do that yet. If you have ever worked in AutoCAD, you would know exactly what I’m talking about. Being able to quickly snap to your intended points quickly helps productivity quite a bit.
As to the hip axes problem, you’re demonstrating the problem that I was running into. Your Z axis is perpendicular to the adjacent roof surface, not the hip line.

Couldn’t agree more. I realized from the get that I had to learn a brand new language, and have a long way to go. But that shouldn’t stop the Sketchup team from getting up to speed with industry standards. The competition out there is steep, and falling behind can be lethal. Don’t know if you’re familiar with a company from the past named Ashton Tate, but they were the big boy in the industry with dBASE. They came out with version 4 of dBASE which had serious flaws. They did not respond quickly enough, and ploughed ahead with version 5. It’s why most people today have never heard of Ashton Tate.

The Z axis shown by Dave is perpendicular to the hip line. Dave decided to snap the green axis to one of the two roof faces that intersect at the hip line. Since there can be an infinite number of perpendicular lines around another line you have to decide which one you want. If you want the blue axis to be oriented so that it makes the same angle with both roof faces, you need another method.

See this SU file for ideas.

Perpendicular to roof hip line.skp (98.0 KB)

2 Likes

If you look at the model I submitted, the work planes were put there to visually confirm that the blue axis was truly perpendicular to the hip line. The importance of this is that if one is creating 3D components to install on the hip line, such as ridge caps or flashing, then the axes must be correct to install the components. Also, take note that the model rectangular. Therefore, the surface angles of the adjacent roof surfaces are not the same. This can really create problems if your axes are not correct. I come from a construction background, and I can assure you that dealing with the complexities of hip roofs is a real challenge. So, since I’m new to Sketchup, I was wondering if there is some recognized method to correctly align the axes to the hip line. I drove myself nuts trying to do it, and my ultimate solution seems a bit odd to me. I can’t fully explain how to execute the final step. There must be a better way.

My guess is that you want to bisect the angle between the adjacent roofplanes with a line perpendicular to the hipline. That’s different from just perpendicular as a line has an infinite number of perpendicular lines around itself at any given point…

Yes, it comes down to what one is considering as “perpendicular”. That’s why I included the work planes in my model, so as to define what I want the Z axis to be perpendicular to.

I’m not sure exactly why you want to change the axis, but if you want to align to that plane the Pie tool will help you.
pie ridge