Snaps to the wrong point


#1

Hi,

I have a problem with snaps. In my model when I want to draw a line from particular point it snaps to the wrong place. It looks like the snap is shifted by some sort of length (always the same from every point). File I am working on is quite big and was modified by many people. What can be a problem?

Here is a view: line should be drawn from the corner


#2

Try adjusting the units.
Go window/Model info units tab and untick length snapping.
You could adjust the precision while you are there.


#3

@Box, respectfully, I disagree. My experience has been that once a Vertex is created, the inference engine will find it and snap to it regardless of the “length snap” setting. Rather, that setting determines what lengths can be used for new Edges that you create using the cursor.

I think it more likely that @Yoona is falling victim to a variant of the small scale “Edge capture” effect that was recently discussed here:

I think that the end Vertices of the Edges that appear to meet at that corner are slightly off from each other (i.e. within SketchUp’s 0.001 inch tolerance). It’s also possible that there is hidden or other-context geometry very close to the corner but not visible. The inference engine flags one Vertex, but then the cleanup operation decides there is a end-intersection with one of the other Edges. When this happens, SketchUp “fixes” it by drawing the new edge to the end of the other Edge instead of to where the inference engine marker was located. That is, it concludes the other pre-existing Edge is right and it should adjust the new one instead of the other way around.

This happens only when working at very small scale, aka very high zoom, and only when there are very small errors or very small objects in the model. @Yoona, how large are the objects in your picture?


#4

I said ‘try’ in my post for this very reason.
It is unclear from the image what is happening and I am only on a phone. So if my suggestion worked then so be it, if it didn’t then we had a better way to go with answers.
I would have asked for the model but can’t do anything with it on a phone.


#5

I will explain a situation a bit more. I got a 3d model of existing part of the city. This problem has already existed in this file. It applied to every point. It was impossible to “catch” the right point because it always moved it off a specific length. Then I created a new model in the new file and everything was good until I copied it to the existing model. Then the same problem appeared for both parts. Now even when I copy it back to the new file, problem stays. So I suppose it must be sth with settings. It is not possible there are some hidden lines. I tried scaling it and changing precision but it doesn’t help so far.


#6

Is it possible for you to post part or all of your model somewhere the experts can study it?


#7

Off the point.skp (783.2 KB)

Here is the part of the model. Now when I extracted it I saw that there is some kind of hidden geometry. I must say it didn’t exist when I created this file at first. Problem has started when I copied it into the file I got from planning department.


#8

Based on a quick look, you are falling victim to another of SketchUp’s finite-precision limits: your geometry is located an excessive distance from the model’s origin (as in many kilometers!). Move the model contents to the origin by activating the move tool, moving a small amount and then typing [0,0,0] into the VCB. Then zoom extents to get your model back into view.

Edit: that is definitely an issue, but there must be more going on - the fix above causes the contents to disappear on my copy…stay tuned. Aha, that was a clipping plane issue due again to the huge original distance from the origin. Flipping back and forth between parallel and perspective and zoom extents fixed it. Well, almost - I still get zoom issues with the clipping plane.


#9

Classic clipping issues.
Too late at night for me to go into it.
Others may explain while I sleep, or search for Clipping Plane.


#10

OK, your entire model is almost surely mis-scaled! Is that section of the city supposed to be 260 km across? That’s what I measure! That is too large for SketchUp to handle correctly.


#11

I have changed the scale just to try many options. It didn’t change
anything.


#12

Do you mean that you changed the Units in Model Info, or that you selected and then scaled the model using the scale tool? Changing the model units won’t change the modeled size or location or the contents, only the way that values are presented and VCB input is interpreted by default.

Try this:

  • first make the Terreng layer non-visible, then select all (ctrl-A) and delete the stray edge that is outside the group
  • next turn Terreng back to visible, select the group, activate the scale tool, pick one of the diagonal corners of the bounding box, and type 0.01 into the VCB (I’m guessing the model is mis-scaled by 100, since 3 km seems like a more likely correct size)
  • do a zoom extents, since the model will now be too small to see
  • then activate the move tool, wiggle a bit and type [0,0,0] into the VCB to move the Group to the model origin
  • now do a zoom extents and all will be healed!

#13

Does it work on your computer? Because I have tried it and it doesn’t work.
When I exploded the groups after all geometry completely gone mad.
By scaling I meant units but also I used tape measure tool to scale. I draw
a line which has 10000 measured it and type 10 instead and then it rescaled
the whole model. But I still haven’t solved the problem. Maybe I should
install cleanup.


#14

I drew a single line from the model to the Origin.
This is the length (in meters) of the edge!

It’s easier to read with spaces added … ~ 6 669 234 672m

Move the model to the Origin.
Select it, begin the move operation, then simply type [0,0,0] and hit Enter.
Then scale the model down to real-world size.
As it is, the cylindrical building is some 40000m in diameter.

BTW … How did you do that?


#15

As I have written few times before I scaled the model just for trying many options since nth has worked. This is not the reason of the problem! I am uploading now scaled model with the same problem. Try to draw a line from any point.Off the point.skp (786.8 KB)


#16

Moving model to the origin helps though. But still drawing the line from the point it is not as usual. The model I created was fine. I explained everything at the beginning of this post. I have model of entire city any many people were working on it so I don’t know when and how the problem begun.


#17

Well, this is what I got by following my procedure:

Off the point.skp (807.6 KB)


#18

Upss I have 2013 version… Can’t open it.


#19

The model is still 6669151m from the Origin.
SketchUp simply won’t work right with the model that far away from the Origin.

There is also a lot of stray hidden geometry in the model.

Here’s a cleaned-up copy, moved to the Origin and scaled to reasonable real-world size.

Saved As SU v2013
Off the point- Fixed.skp (612.2 KB)


#20

Off the point 2013.skp (807.2 KB)